summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-09-30 20:08:29 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-30 20:46:11 +0100
commit96235897e6cb93f636283edbf30bf8fda93e002a (patch)
treefbdd6f1e59b36cdcd7ef39842361909570003655 /meta/recipes-graphics
parent27b68f9f4c178c60e7095001a7dda3864068c6ae (diff)
downloadopenembedded-core-96235897e6cb93f636283edbf30bf8fda93e002a.tar.gz
moblin-proto: Move to meta-extras
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/clutter/moblin-proto/fix-shader-and-callbacks.patch44
-rw-r--r--meta/recipes-graphics/clutter/moblin-proto/fix.patch22
-rw-r--r--meta/recipes-graphics/clutter/moblin-proto/paths.patch15
-rw-r--r--meta/recipes-graphics/clutter/moblin-proto_git.bb19
4 files changed, 0 insertions, 100 deletions
diff --git a/meta/recipes-graphics/clutter/moblin-proto/fix-shader-and-callbacks.patch b/meta/recipes-graphics/clutter/moblin-proto/fix-shader-and-callbacks.patch
deleted file mode 100644
index 4a3eddb8cd..0000000000
--- a/meta/recipes-graphics/clutter/moblin-proto/fix-shader-and-callbacks.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff --git a/Makefile b/Makefile
-index e05b5b7..c348a1e 100644
---- a/Makefile
-+++ b/Makefile
-@@ -64,7 +64,7 @@ HFILES = $(wildcard *.h)
- %.o: %.c $(HFILES)
- $(CC) -g $(CFLAGS) $(INCS) -c $< -o$@
- $(BINARY): $(OBJECTS)
-- $(CXX) -o $@ $(OBJECTS) $(LIBS)
-+ $(CXX) -rdynamic -o $@ $(OBJECTS) $(LIBS)
-
- #$(BINARY): $(CFILES)
- # $(LD) $(CFLAGS) $(INCS) $(CFILES) $(LIBS) -o $@
-diff --git a/moblin-desktop.c b/moblin-desktop.c
-index 6dd4f2c..fb9d231 100644
---- a/moblin-desktop.c
-+++ b/moblin-desktop.c
-@@ -103,6 +103,8 @@ void moblin_blur (void)
- if (desktop->maincopy)
- return;
-
-+ if (clutter_feature_available (CLUTTER_FEATURE_SHADERS_GLSL))
-+ {
- #if 0
- desktop->maincopy = clutter_texture_new_from_actor (desktop->mainstuff);
- #else
-@@ -158,6 +160,17 @@ void moblin_blur (void)
- 1.0f / moblin_desktop_width ());
- }
- clutter_actor_set_shader_param (desktop->maincopy, "radius", 3.0);
-+ }
-+ else
-+ {
-+ ClutterColor clr= { 0x44, 0x44, 0x44, 0x77 };
-+ guint w, h;
-+
-+ desktop->maincopy = clutter_rectangle_new_with_color (&clr);
-+ clutter_actor_get_size (desktop->mainstuff, &w, &h);
-+ clutter_actor_set_size (desktop->maincopy, w, h);
-+ clutter_group_add (desktop->copyholder, desktop->maincopy);
-+ }
- }
-
- void moblin_unblur (void)
diff --git a/meta/recipes-graphics/clutter/moblin-proto/fix.patch b/meta/recipes-graphics/clutter/moblin-proto/fix.patch
deleted file mode 100644
index 8bde67762c..0000000000
--- a/meta/recipes-graphics/clutter/moblin-proto/fix.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Index: git/Makefile
-===================================================================
---- git.orig/Makefile 2008-08-11 22:49:48.000000000 +0100
-+++ git/Makefile 2008-08-12 12:16:52.000000000 +0100
-@@ -15,7 +15,7 @@
-
- SCP_DESTINATION=pug.vpn:tmp
-
--BINARY=$(shell basename `pwd`)#
-+BINARY=moblin-proto
- PACKAGE=../$(BINARY).tar.bz2 # you can use both .gz and .bz2 as extension here
-
- #CFLAGS= -Wall -I /home/pippin/src/clutter-box2d/clutter-box2d
-@@ -61,7 +61,7 @@
- %.o: %.c $(HFILES)
- $(CC) -g $(CFLAGS) $(INCS) -c $< -o$@
- $(BINARY): $(OBJECTS)
-- $(CC) -o $@ $(OBJECTS) $(LIBS)
-+ $(CXX) -o $@ $(OBJECTS) $(LIBS)
-
- #$(BINARY): $(CFILES)
- # $(LD) $(CFLAGS) $(INCS) $(CFILES) $(LIBS) -o $@
diff --git a/meta/recipes-graphics/clutter/moblin-proto/paths.patch b/meta/recipes-graphics/clutter/moblin-proto/paths.patch
deleted file mode 100644
index d241c8ff71..0000000000
--- a/meta/recipes-graphics/clutter/moblin-proto/paths.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/moblin-desktop.h b/moblin-desktop.h
-index 880a9ad..3d51a14 100644
---- a/moblin-desktop.h
-+++ b/moblin-desktop.h
-@@ -29,8 +29,8 @@
- #define __MAIN_H__
-
-
--#define ASSET_ROOT "./assets/"
--#define JSON_ROOT "./layouts/"
-+#define ASSET_ROOT "/usr/share/moblin-proto/assets/"
-+#define JSON_ROOT "/usr/share/moblin-proto/layouts/"
-
- typedef struct
- {
diff --git a/meta/recipes-graphics/clutter/moblin-proto_git.bb b/meta/recipes-graphics/clutter/moblin-proto_git.bb
deleted file mode 100644
index b86d622385..0000000000
--- a/meta/recipes-graphics/clutter/moblin-proto_git.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-DEPENDS = "clutter-box2d"
-
-PV = "0.0+git${SRCPV}"
-PR = "r2"
-
-SRC_URI = "git://moblin.org/repos/users/pippin/prototype.git/;protocol=http \
- file://paths.patch;patch=1 \
- file://fix-shader-and-callbacks.patch;patch=1"
-
-S = "${WORKDIR}/git"
-
-do_install () {
- install -d ${D}${bindir}
- install ${S}/moblin-proto ${D}${bindir}
-
- install -d ${D}${datadir}/moblin-proto/
- cp -a ${S}/assets ${D}${datadir}/moblin-proto/
- cp -a ${S}/layouts ${D}${datadir}/moblin-proto/
-}