summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-09-19 18:04:11 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-09-21 23:44:04 +0100
commit777d9744570c2dc119dc5d04985896bbb1da5885 (patch)
treed80a6f6486d74a9722d70af3c1df676e7470a72d /meta/recipes-graphics
parent6f5770b49f06168e3d6914bd92f0594bd05f1f8f (diff)
downloadopenembedded-core-777d9744570c2dc119dc5d04985896bbb1da5885.tar.gz
recipes: Add missing pkgconfig inherit
Various recipes were missing a pkgconfig inherit or pkgconfig-native dependency despite using pkgconfig. Add the inherit to igt-gpu-tools/gdb/libmodulemd/libwpe/xwayland/waffle shaderc/iputils/wpebackend-fdo/lttng-ust/cargo. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/igt-gpu-tools/igt-gpu-tools_git.bb2
-rw-r--r--meta/recipes-graphics/shaderc/shaderc_2021.1.bb2
-rw-r--r--meta/recipes-graphics/waffle/waffle_1.6.1.bb2
-rw-r--r--meta/recipes-graphics/xwayland/xwayland_21.1.2.bb2
4 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-graphics/igt-gpu-tools/igt-gpu-tools_git.bb b/meta/recipes-graphics/igt-gpu-tools/igt-gpu-tools_git.bb
index 79fab7a28a..1a00eca7d3 100644
--- a/meta/recipes-graphics/igt-gpu-tools/igt-gpu-tools_git.bb
+++ b/meta/recipes-graphics/igt-gpu-tools/igt-gpu-tools_git.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=67bfee4df38fa6ecbe3a675c552d4c08"
LICENSE = "MIT"
-inherit meson
+inherit meson pkgconfig
SRCREV = "203def046b466fb2da67f9f15552d84e1c0b41f2"
PV = "1.26"
diff --git a/meta/recipes-graphics/shaderc/shaderc_2021.1.bb b/meta/recipes-graphics/shaderc/shaderc_2021.1.bb
index e15b5794ee..ad3f62ce17 100644
--- a/meta/recipes-graphics/shaderc/shaderc_2021.1.bb
+++ b/meta/recipes-graphics/shaderc/shaderc_2021.1.bb
@@ -14,7 +14,7 @@ SRC_URI = "git://github.com/google/shaderc.git;protocol=https;branch=main \
UPSTREAM_CHECK_GITTAGREGEX = "^v(?P<pver>\d+(\.\d+)+)$"
S = "${WORKDIR}/git"
-inherit cmake python3native
+inherit cmake python3native pkgconfig
DEPENDS = "spirv-headers spirv-tools glslang"
diff --git a/meta/recipes-graphics/waffle/waffle_1.6.1.bb b/meta/recipes-graphics/waffle/waffle_1.6.1.bb
index fa5efc12c4..395494018a 100644
--- a/meta/recipes-graphics/waffle/waffle_1.6.1.bb
+++ b/meta/recipes-graphics/waffle/waffle_1.6.1.bb
@@ -15,7 +15,7 @@ SRC_URI[sha256sum] = "31565649ff0e2d8dff1b8f7f2264ab7a78452063c7e04adfc4ce03e64b
UPSTREAM_CHECK_URI = "http://www.waffle-gl.org/releases.html"
-inherit meson features_check lib_package bash-completion
+inherit meson features_check lib_package bash-completion pkgconfig
DEPENDS:append = " python3"
diff --git a/meta/recipes-graphics/xwayland/xwayland_21.1.2.bb b/meta/recipes-graphics/xwayland/xwayland_21.1.2.bb
index 3df6fd1ff9..6aba65935b 100644
--- a/meta/recipes-graphics/xwayland/xwayland_21.1.2.bb
+++ b/meta/recipes-graphics/xwayland/xwayland_21.1.2.bb
@@ -14,7 +14,7 @@ SRC_URI[sha256sum] = "b81cbdd5ad60b8b7ad8c3ecc7ec2a28c9bf021448670735cebb501f08b
UPSTREAM_CHECK_REGEX = "xwayland-(?P<pver>\d+(\.(?!90\d)\d+)+)\.tar"
-inherit meson features_check
+inherit meson features_check pkgconfig
REQUIRED_DISTRO_FEATURES = "x11 opengl"
DEPENDS += "xorgproto xtrans pixman libxkbfile libxfont2 wayland wayland-native wayland-protocols libdrm libepoxy"