summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-07-07 10:45:06 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-08 23:01:54 +0100
commit4f36a7f698de5056cb38641a7bf12921dba7d962 (patch)
tree8e477eb05d582177844ba95567007e9792fbe945 /meta/recipes-graphics
parente2f19080954c90188d27508bda4e8493e9ede12c (diff)
downloadopenembedded-core-4f36a7f698de5056cb38641a7bf12921dba7d962.tar.gz
libx11: enable xcb support
[YOCTO #1196] XCB support is needed in libx1l, it has been enabled in libx11-trim for sometime and was not in full version. The usage here is for LSB testing, which uses full libx11. Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/xorg-lib/libx11_1.3.4.bb11
1 files changed, 8 insertions, 3 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libx11_1.3.4.bb b/meta/recipes-graphics/xorg-lib/libx11_1.3.4.bb
index 3e046a16af..04d4a97b95 100644
--- a/meta/recipes-graphics/xorg-lib/libx11_1.3.4.bb
+++ b/meta/recipes-graphics/xorg-lib/libx11_1.3.4.bb
@@ -5,7 +5,7 @@ LICENSE = "MIT & MIT-style & BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=bf75bfe4d05068311b5e6862d4b5f2c5"
PE = "1"
-PR = "r1"
+PR = "r3"
SRC_URI += "file://x11_disable_makekeys.patch \
file://nodolt.patch \
@@ -16,8 +16,13 @@ SRC_URI[md5sum] = "f65c9c7ecbfb64c19dbd7927160d63fd"
SRC_URI[sha256sum] = "88d7238ce5f7cd123450567de7a3b56a43556e4ccc45df38b8324147c889a844"
DEPENDS += "bigreqsproto xproto xextproto xtrans libxau xcmiscproto \
- libxdmcp xf86bigfontproto kbproto inputproto xproto-native"
+ libxdmcp xf86bigfontproto kbproto inputproto xproto-native libxcb"
-EXTRA_OECONF += "--without-xcb"
+DEPENDS_virtclass-native += "bigreqsproto-native xproto-native xextproto-native xtrans-native libxau-native xcmiscproto-native \
+ libxdmcp-native xf86bigfontproto-native kbproto-native inputproto-native xproto-native"
+
+XCB = "--with-xcb"
+XCB_virtclass-native = "--without-xcb"
+EXTRA_OECONF += "${XCB}"
BBCLASSEXTEND = "native nativesdk"