summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2023-06-22 15:39:13 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-06-24 12:19:53 +0100
commit49f4dd391b408a850d13010c90492c621b7912c3 (patch)
treece14672e2b2075c5e760856ccb180eb9e0471bab /meta/recipes-graphics/wayland
parent86cc1a595011ff08fb50bca7215e5b22cda6cdcb (diff)
downloadopenembedded-core-49f4dd391b408a850d13010c90492c621b7912c3.tar.gz
weston: Cleanup and fix x11 and xwayland dependencies
For the x11 backend package config, drop the redundant dependencies libxcb and cairo. The former is listed twice in the package config, while the latter is also listed globally. For the xwayland package config, add the missing dependencies libxcb and libxcursor. These dependencies are hidden when the x11 backend is enabled by default. When the default setting is overridden to disable the x11 backend, the following error occurs: ``` | Run-time dependency xcursor found: NO (tried pkgconfig and cmake) | | ../git/xwayland/meson.build:34:2: ERROR: Problem encountered: xwayland requires xcursor which was not found. Or, you can use '-Dxwayland=false'. ``` Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/wayland')
-rw-r--r--meta/recipes-graphics/wayland/weston_11.0.1.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-graphics/wayland/weston_11.0.1.bb b/meta/recipes-graphics/wayland/weston_11.0.1.bb
index 4f6ce19915..0838791a6b 100644
--- a/meta/recipes-graphics/wayland/weston_11.0.1.bb
+++ b/meta/recipes-graphics/wayland/weston_11.0.1.bb
@@ -57,7 +57,7 @@ PACKAGECONFIG[kms] = "-Dbackend-drm=true,-Dbackend-drm=false,drm udev virtual/eg
# Weston on Wayland (nested Weston)
PACKAGECONFIG[wayland] = "-Dbackend-wayland=true,-Dbackend-wayland=false,virtual/egl virtual/libgles2"
# Weston on X11
-PACKAGECONFIG[x11] = "-Dbackend-x11=true,-Dbackend-x11=false,virtual/libx11 libxcb libxcb libxcursor cairo"
+PACKAGECONFIG[x11] = "-Dbackend-x11=true,-Dbackend-x11=false,virtual/libx11 libxcb libxcursor"
# Headless Weston
PACKAGECONFIG[headless] = "-Dbackend-headless=true,-Dbackend-headless=false"
# Weston on RDP
@@ -73,7 +73,7 @@ PACKAGECONFIG[webp] = "-Dimage-webp=true,-Dimage-webp=false,libwebp"
# Weston with systemd-login support
PACKAGECONFIG[systemd] = "-Dsystemd=true -Dlauncher-logind=true,-Dsystemd=false -Dlauncher-logind=false,systemd dbus"
# Weston with Xwayland support (requires X11 and Wayland)
-PACKAGECONFIG[xwayland] = "-Dxwayland=true,-Dxwayland=false,xwayland"
+PACKAGECONFIG[xwayland] = "-Dxwayland=true,-Dxwayland=false,libxcb libxcursor xwayland"
# colord CMS support
PACKAGECONFIG[colord] = "-Ddeprecated-color-management-colord=true,-Ddeprecated-color-management-colord=false,colord"
# Clients support