summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/files/0001-Simplify-wayland-scanner-lookup.patch
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-08-30 14:27:37 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-09-04 11:03:31 +0100
commita77eb44bb1ff2ece9dcff1f7b5fe671ea3ae034d (patch)
tree9fadf37847d5a392d75f04e86754fd081119b5f2 /meta/recipes-graphics/mesa/files/0001-Simplify-wayland-scanner-lookup.patch
parent1b980f95112f83f713de9c70f3e1d64996dcade0 (diff)
downloadopenembedded-core-a77eb44bb1ff2ece9dcff1f7b5fe671ea3ae034d.tar.gz
mesa: Upgrade 18.1.3 -> 18.1.7
This upgrades mesa to the 18.1.7 stable release. The changes can be found at: https://www.mesa3d.org/relnotes/18.1.4.html https://www.mesa3d.org/relnotes/18.1.5.html https://www.mesa3d.org/relnotes/18.1.6.html https://www.mesa3d.org/relnotes/18.1.7.html Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/mesa/files/0001-Simplify-wayland-scanner-lookup.patch')
-rw-r--r--meta/recipes-graphics/mesa/files/0001-Simplify-wayland-scanner-lookup.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/files/0001-Simplify-wayland-scanner-lookup.patch b/meta/recipes-graphics/mesa/files/0001-Simplify-wayland-scanner-lookup.patch
new file mode 100644
index 0000000000..a50d2a2ba2
--- /dev/null
+++ b/meta/recipes-graphics/mesa/files/0001-Simplify-wayland-scanner-lookup.patch
@@ -0,0 +1,39 @@
+From 7e8e0f8a8ac2425e19a2f340c9e3da9345f25940 Mon Sep 17 00:00:00 2001
+From: Jussi Kukkonen <jussi.kukkonen@intel.com>
+Date: Tue, 15 Nov 2016 15:20:49 +0200
+Subject: [PATCH 1/6] Simplify wayland-scanner lookup
+Organization: O.S. Systems Software LTDA.
+
+Don't use pkg-config to lookup the path of a binary that's in the path.
+
+Alternatively we'd have to prefix the path returned by pkg-config with
+PKG_CONFIG_SYSROOT_DIR.
+
+Upstream-Status: Pending
+Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
+Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
+---
+ configure.ac | 7 +------
+ 1 file changed, 1 insertion(+), 6 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 14f1af2b2f..916d0bd207 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1825,12 +1825,7 @@ for plat in $platforms; do
+ PKG_CHECK_MODULES([WAYLAND_PROTOCOLS], [wayland-protocols >= $WAYLAND_PROTOCOLS_REQUIRED])
+ WAYLAND_PROTOCOLS_DATADIR=`$PKG_CONFIG --variable=pkgdatadir wayland-protocols`
+
+- PKG_CHECK_MODULES([WAYLAND_SCANNER], [wayland-scanner],
+- WAYLAND_SCANNER=`$PKG_CONFIG --variable=wayland_scanner wayland-scanner`,
+- WAYLAND_SCANNER='')
+- if test "x$WAYLAND_SCANNER" = x; then
+- AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner], [:])
+- fi
++ AC_PATH_PROG([WAYLAND_SCANNER], [wayland-scanner], [:])
+
+ if test "x$WAYLAND_SCANNER" = "x:"; then
+ AC_MSG_ERROR([wayland-scanner is needed to compile the wayland platform])
+--
+2.18.0
+