summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-05-05 17:18:47 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-05-09 23:23:23 +0100
commitf87bb7d848015c371095ef3ff423eee81e6d8ecd (patch)
tree9ba41dfc8fd59b9668ba05e6f486f846b6dc7b3b /meta/recipes-gnome
parentb557ea3cc61da326bb7783a2ac8e4080c4bf79e5 (diff)
downloadopenembedded-core-f87bb7d848015c371095ef3ff423eee81e6d8ecd.tar.gz
gi-docgen: add a recipe and class
This seems to be the gtk-doc successor, and gnome projects such as pango and gdk-pixbuf have started transitioning to it. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-gnome')
-rw-r--r--meta/recipes-gnome/gi-docgen/gi-docgen_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gi-docgen/gi-docgen_git.bb b/meta/recipes-gnome/gi-docgen/gi-docgen_git.bb
new file mode 100644
index 0000000000..4d779a9bdd
--- /dev/null
+++ b/meta/recipes-gnome/gi-docgen/gi-docgen_git.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Documentation tool for GObject-based libraries"
+DESCRIPTION = "GI-DocGen is a document generator for GObject-based libraries. GObject is \
+the base type system of the GNOME project. GI-Docgen reuses the \
+introspection data generated by GObject-based libraries to generate the API \
+reference of these libraries, as well as other ancillary documentation."
+HOMEPAGE = "https://gnome.pages.gitlab.gnome.org/gi-docgen/"
+
+LICENSE = "GPLv3+ & Apache-2.0"
+LIC_FILES_CHKSUM = "file://gi-docgen.py;beginline=1;endline=5;md5=2dc0f1f01202478cfe813c0e7f80b326"
+
+SRC_URI = "git://gitlab.gnome.org/GNOME/gi-docgen.git;protocol=https;branch=main"
+
+PV = "2021.5"
+SRCREV = "7dee859321573f9c843ef7fb136f11142cb6ddf8"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+RDEPENDS_${PN} += "python3-asyncio python3-core python3-jinja2 python3-json python3-markdown python3-markupsafe python3-pygments python3-toml python3-typogrify python3-xml"
+
+BBCLASSEXTEND = "native"