summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-06-17 12:15:52 +0200
committerSteve Sakoman <steve@sakoman.com>2020-07-10 17:11:12 -1000
commit80b61573fd1509cb46d263d6adb3621c3dee15d1 (patch)
tree78c8942e3301f6cac3cc324a6dd02e1c5973ea0a /meta/recipes-gnome
parentcabaf5654db5db12b6576ef0ebae9bc7b422a8ca (diff)
downloadopenembedded-core-80b61573fd1509cb46d263d6adb3621c3dee15d1.tar.gz
gobject-introspection: add a patch to fix a build race
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 1d6ffc795fc815509e193b28df3a33cc72bfb31b) Signed-off-by: Steve Sakoman <steve@sakoman.com>
Diffstat (limited to 'meta/recipes-gnome')
-rw-r--r--meta/recipes-gnome/gobject-introspection/gobject-introspection/0001-gir-add-a-dependency-for-g-ir-compiler-for-building-.patch33
-rw-r--r--meta/recipes-gnome/gobject-introspection/gobject-introspection_1.62.0.bb1
2 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-gnome/gobject-introspection/gobject-introspection/0001-gir-add-a-dependency-for-g-ir-compiler-for-building-.patch b/meta/recipes-gnome/gobject-introspection/gobject-introspection/0001-gir-add-a-dependency-for-g-ir-compiler-for-building-.patch
new file mode 100644
index 0000000000..adb357b5ec
--- /dev/null
+++ b/meta/recipes-gnome/gobject-introspection/gobject-introspection/0001-gir-add-a-dependency-for-g-ir-compiler-for-building-.patch
@@ -0,0 +1,33 @@
+From 56ba5656258b82dbc069ab3a61e597c931a16a83 Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Wed, 17 Jun 2020 11:43:16 +0200
+Subject: [PATCH] gir: add a dependency for g-ir-compiler for building .girs
+
+meson inserts the dependency if the compiler is used directly, but
+fails to do so if the compiler is run through a wrapper. This leads
+to build race errors between building the compiler and using it.
+
+Fix provided by Quentin Schulz <quentin.schulz@streamunlimited.com>
+
+Upstream-Status: Accepted [https://gitlab.gnome.org/GNOME/gobject-introspection/-/merge_requests/228]
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ gir/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/gir/meson.build b/gir/meson.build
+index b37fdb81..557e5517 100644
+--- a/gir/meson.build
++++ b/gir/meson.build
+@@ -448,7 +448,7 @@ foreach gir : gir_files
+ typelibs += custom_target('generate-typelib-@0@'.format(gir).underscorify(),
+ input: gir,
+ output: '@BASENAME@.typelib',
+- depends: [gobject_gir, ],
++ depends: [gobject_gir, gircompiler, ],
+ command: gircompiler_command,
+ install: true,
+ install_dir: typelibdir,
+--
+2.27.0
+
diff --git a/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.62.0.bb b/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.62.0.bb
index b1371776af..92b0d1d52f 100644
--- a/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.62.0.bb
+++ b/meta/recipes-gnome/gobject-introspection/gobject-introspection_1.62.0.bb
@@ -22,6 +22,7 @@ SRC_URI = "${GNOME_MIRROR}/${BPN}/${@oe.utils.trim_version("${PV}", 2)}/${BPN}-$
file://0001-Port-cross-compilation-support-to-meson.patch \
file://0001-meson.build-disable-tests-when-cross-compiling.patch \
file://0001-Fix-build-reproducibility.patch \
+ file://0001-gir-add-a-dependency-for-g-ir-compiler-for-building-.patch \
"
SRC_URI[md5sum] = "37278eab3704e42234b6080b8cf241f1"