summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2024-02-12 17:44:56 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-02-13 13:51:38 +0000
commit7f9d0f331ce5b5292117b3d8c23f747a369cfde6 (patch)
treecde45b53de3fafc05666d9411b726275d0f0e6cd /meta/recipes-extended
parent74bd5ea29c8e2c607e9b982028c103abebcd0b27 (diff)
downloadopenembedded-core-7f9d0f331ce5b5292117b3d8c23f747a369cfde6.tar.gz
libpam: remove redundant PTEST_ENABLED conditional
do_install_ptest is only called if ptest is enabled, so don't guard it again. Signed-off-by: Ross Burton <ross.burton@arm.com>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/pam/libpam_1.5.3.bb8
1 files changed, 3 insertions, 5 deletions
diff --git a/meta/recipes-extended/pam/libpam_1.5.3.bb b/meta/recipes-extended/pam/libpam_1.5.3.bb
index 809d927f55..4dd9890606 100644
--- a/meta/recipes-extended/pam/libpam_1.5.3.bb
+++ b/meta/recipes-extended/pam/libpam_1.5.3.bb
@@ -163,11 +163,9 @@ do_install() {
}
do_install_ptest() {
- if [ ${PTEST_ENABLED} = "1" ]; then
- mkdir -p ${D}${PTEST_PATH}/tests
- install -m 0755 ${B}/tests/.libs/* ${D}${PTEST_PATH}/tests
- install -m 0644 ${S}/tests/confdir ${D}${PTEST_PATH}/tests
- fi
+ mkdir -p ${D}${PTEST_PATH}/tests
+ install -m 0755 ${B}/tests/.libs/* ${D}${PTEST_PATH}/tests
+ install -m 0644 ${S}/tests/confdir ${D}${PTEST_PATH}/tests
}
pkg_postinst:${PN}() {