summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/rust-example/rust-hello-world_git.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-09-10 17:24:31 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-09-13 10:34:30 +0100
commitc53b2539176199607eb12c706658a269c81d3232 (patch)
tree73381b71b20bdeb9162b04ab5de110897c574a5d /meta/recipes-extended/rust-example/rust-hello-world_git.bb
parentefa88e1c227d695319197f511701e0230d301f39 (diff)
downloadopenembedded-core-c53b2539176199607eb12c706658a269c81d3232.tar.gz
rust-hello-world: move to recipes-extended
There is no need to have a single recipe in recipes-example; moving it to recipes-extended put it with other recipes. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/rust-example/rust-hello-world_git.bb')
-rw-r--r--meta/recipes-extended/rust-example/rust-hello-world_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-extended/rust-example/rust-hello-world_git.bb b/meta/recipes-extended/rust-example/rust-hello-world_git.bb
new file mode 100644
index 0000000000..1d91109b51
--- /dev/null
+++ b/meta/recipes-extended/rust-example/rust-hello-world_git.bb
@@ -0,0 +1,19 @@
+inherit cargo
+
+SRC_URI = "git://github.com/meta-rust/rust-hello-world.git;protocol=https;branch=master"
+SRCREV="e0fa23f1a3cb1eb1407165bd2fc36d2f6e6ad728"
+LIC_FILES_CHKSUM="file://COPYRIGHT;md5=e6b2207ac3740d2d01141c49208c2147"
+
+SRC_URI += "\
+ file://0001-enable-LTO.patch \
+ "
+
+UPSTREAM_CHECK_COMMITS = "1"
+
+SUMMARY = "Hello World by Cargo for Rust"
+HOMEPAGE = "https://github.com/meta-rust/rust-hello-world"
+LICENSE = "MIT | Apache-2.0"
+
+S = "${WORKDIR}/git"
+
+BBCLASSEXTEND = "native"