summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
diff options
context:
space:
mode:
authorJoshua Lock <joshua.g.lock@intel.com>2016-12-14 21:13:04 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-12-16 08:30:03 +0000
commit7c552996597faaee2fbee185b250c0ee30ea3b5f (patch)
treebb74186da3e2d4b03c33875a71fbe340ba09a0d7 /meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
parent84ec50e587e7464b260b1b189659b93b6dab0ef6 (diff)
downloadopenembedded-core-7c552996597faaee2fbee185b250c0ee30ea3b5f.tar.gz
meta: remove True option to getVar calls
getVar() now defaults to expanding by default, thus remove the True option from getVar() calls with a regex search and replace. Search made with the following regex: getVar ?\(( ?[^,()]*), True\) Signed-off-by: Joshua Lock <joshua.g.lock@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb')
-rw-r--r--meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb b/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
index 29564e0c9d..734dda1d79 100644
--- a/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
+++ b/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
@@ -15,9 +15,9 @@ REQUIRED_DISTRO_FEATURES = "x11"
# We will skip parsing this packagegeoup for non-glibc systems
#
python __anonymous () {
- if d.getVar('TCLIBC', True) != "glibc":
+ if d.getVar('TCLIBC') != "glibc":
raise bb.parse.SkipPackage("incompatible with %s C library" %
- d.getVar('TCLIBC', True))
+ d.getVar('TCLIBC'))
}
PACKAGES = "\