summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libsolv/libsolv_0.7.3.bb
diff options
context:
space:
mode:
authorAlejandro del Castillo <alejandro.delcastillo@ni.com>2019-02-01 11:06:55 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-02-02 08:43:34 +0000
commita0f78447a14cf17ce4ae03a97ed4f703cbe1af2b (patch)
treedf3b62351aff2fec473891bf3aa75c3543a6f3fd /meta/recipes-extended/libsolv/libsolv_0.7.3.bb
parent966b245a3a4fda1dc1333194e88fdbac34331b6a (diff)
downloadopenembedded-core-a0f78447a14cf17ce4ae03a97ed4f703cbe1af2b.tar.gz
libsolv: upgrade 0.7.2 -> 0.7.3
from NEWS: - selected bug fixes: * fixed a couple of null pointer derefs and potential memory leaks * made disfavoring recommended packages work if strong recommends is enabled * no longer disable infarch rules when they don't conflict with the job - new features: * do favor evaluation before pruning allowing to (dis)favor specific package versions Signed-off-by: Alejandro del Castillo <alejandro.delcastillo@ni.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/libsolv/libsolv_0.7.3.bb')
-rw-r--r--meta/recipes-extended/libsolv/libsolv_0.7.3.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-extended/libsolv/libsolv_0.7.3.bb b/meta/recipes-extended/libsolv/libsolv_0.7.3.bb
new file mode 100644
index 0000000000..7321d63374
--- /dev/null
+++ b/meta/recipes-extended/libsolv/libsolv_0.7.3.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Library for solving packages and reading repositories"
+HOMEPAGE = "https://github.com/openSUSE/libsolv"
+BUGTRACKER = "https://github.com/openSUSE/libsolv/issues"
+SECTION = "devel"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.BSD;md5=62272bd11c97396d4aaf1c41bc11f7d8"
+
+DEPENDS = "expat zlib"
+
+SRC_URI = "git://github.com/openSUSE/libsolv.git"
+SRC_URI_append_libc-musl = " file://0001-Add-fallback-fopencookie-implementation.patch \
+ file://0002-Fixes-to-internal-fopencookie-implementation.patch \
+ "
+
+SRCREV = "dc7d0f1c3113f2c8217563166906bef3eb5d1ee1"
+UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+PACKAGECONFIG ??= "rpm"
+PACKAGECONFIG[rpm] = "-DENABLE_RPMMD=ON -DENABLE_RPMDB=ON,,rpm"
+
+EXTRA_OECMAKE = "-DLIB=${baselib} -DMULTI_SEMANTICS=ON -DENABLE_COMPLEX_DEPS=ON"
+
+PACKAGES =+ "${PN}-tools ${PN}ext"
+
+FILES_${PN}-tools = "${bindir}/*"
+FILES_${PN}ext = "${libdir}/${PN}ext.so.*"
+
+BBCLASSEXTEND = "native nativesdk"