summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/at
diff options
context:
space:
mode:
authorSaul Wold <Saul.Wold@windriver.com>2023-01-11 08:20:26 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-01-12 23:07:39 +0000
commit227c46fe48b64de7574f7b6b407b8c13be71b392 (patch)
tree659b2c22f7dccf5b0feaed10d38eba0a70cef6a7 /meta/recipes-extended/at
parent3ed3b2ffeeaa5d888f77dd30cb8cd81d3275398a (diff)
downloadopenembedded-core-227c46fe48b64de7574f7b6b407b8c13be71b392.tar.gz
at: Change when files are copied
The create_spdx code relies on patched code, if files are changed or added during the do_configure phase they will be missed by the create_spdx process. So we need to ensure files modifications/additions happen in the do_patch phase. Signed-off-by: Saul Wold <saul.wold@windriver.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/at')
-rw-r--r--meta/recipes-extended/at/at_3.2.5.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta/recipes-extended/at/at_3.2.5.bb b/meta/recipes-extended/at/at_3.2.5.bb
index 87a436173f..c0c876a644 100644
--- a/meta/recipes-extended/at/at_3.2.5.bb
+++ b/meta/recipes-extended/at/at_3.2.5.bb
@@ -52,8 +52,10 @@ INITSCRIPT_PARAMS = "defaults"
SYSTEMD_SERVICE:${PN} = "atd.service"
-do_configure:prepend() {
- cp -f ${WORKDIR}/posixtm.[ch] ${S}
+do_patch[postfuncs] += "copy_posix_files"
+
+copy_posix_files() {
+ cp -f ${WORKDIR}/posixtm.[ch] ${S}
}
do_install () {