summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/at/at/fix_parallel_build_error.patch
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2014-08-29 08:26:31 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-31 23:39:11 +0100
commit6558c8e1a7e5cd9f1f5271718c10355f67573b4c (patch)
treedbe780500c43807a37b41025559775ffc051afb6 /meta/recipes-extended/at/at/fix_parallel_build_error.patch
parent5d3c96339e43a777542fa696b300322adbb636e1 (diff)
downloadopenembedded-core-6558c8e1a7e5cd9f1f5271718c10355f67573b4c.tar.gz
at: Upgrade to 3.1.15
Rebase pam.conf.patch Move to generic files -> at for patches directory Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/at/at/fix_parallel_build_error.patch')
-rw-r--r--meta/recipes-extended/at/at/fix_parallel_build_error.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-extended/at/at/fix_parallel_build_error.patch b/meta/recipes-extended/at/at/fix_parallel_build_error.patch
new file mode 100644
index 0000000000..66ff3e1c11
--- /dev/null
+++ b/meta/recipes-extended/at/at/fix_parallel_build_error.patch
@@ -0,0 +1,28 @@
+make -j was failing sometimesa like this
+| ccache i586-poky-linux-gcc -march=i586 --sysroot=/home/nitin/build/build0/tmp/sysroots/i586-poky-linux -I. -fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2 -ggdb -feliminate-unused-debug-types -o atd atd.o daemon.o -lfl -lpam -Wl,-O1 -Wl,--as-needed
+| parsetime.l:5:19: fatal error: y.tab.h: No such file or directory
+| compilation terminated.
+| make: *** [lex.yy.o] Error 1
+| make: *** Waiting for unfinished jobs....
+
+Fixed the issue by adding a dependency in the makefile.
+Nitin <nitin.a.kamble@intel.com>
+2010/09/02
+
+Upstream-Status: Pending
+
+Signed-off-by: Scott Garman <scott.a.garman@intel.com>
+
+Index: at-3.1.12/Makefile.in
+===================================================================
+--- at-3.1.12.orig/Makefile.in
++++ at-3.1.12/Makefile.in
+@@ -83,6 +83,8 @@ y.tab.c y.tab.h: parsetime.y
+ lex.yy.c: parsetime.l
+ $(LEX) -i parsetime.l
+
++parsetime.l: y.tab.h
++
+ atrun: atrun.in
+ configure
+