summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-13 08:16:32 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-14 06:25:47 +0100
commitfe46107e6bf4880d97f03b5e55d722d64f922889 (patch)
treef7f8304d67bc11c15d265235ece992a8cc56e9f0 /meta/recipes-devtools
parent29f6d4be31164bf5cba9ff4706f219b3d91a8f1f (diff)
downloadopenembedded-core-fe46107e6bf4880d97f03b5e55d722d64f922889.tar.gz
python3-testtools: Fix build problems from incorrect build backend
testtools uses the hatchling backend so: * merge the inc back into the recipe * drop setuptools * use the hatchling backend * add the needed vcs dependency * drop the now unneeded python3-pbr dependency This means the submodules are included in packaging, fixing build failures and the verison in the wheel is no longer 0.0.0 Prior to this fix, testtools in buildtools tarball was completely broken. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/python/python-testtools.inc27
-rw-r--r--meta/recipes-devtools/python/python3-testtools_2.7.1.bb21
2 files changed, 19 insertions, 29 deletions
diff --git a/meta/recipes-devtools/python/python-testtools.inc b/meta/recipes-devtools/python/python-testtools.inc
deleted file mode 100644
index e9dd97ec1c..0000000000
--- a/meta/recipes-devtools/python/python-testtools.inc
+++ /dev/null
@@ -1,27 +0,0 @@
-SUMMARY = "Extensions to the Python standard library unit testing framework"
-HOMEPAGE = "https://pypi.org/project/testtools/"
-SECTION = "devel/python"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=e2c9d3e8ba7141c83bfef190e0b9379a"
-
-inherit pypi
-
-SRC_URI[sha256sum] = "df6de96010e29ee21f637a147eabf30d50b25e3841dd1d68f93ee89ce77e366c"
-
-DEPENDS += " \
- python3-pbr \
- "
-
-# Satisfy setup.py 'setup_requires'
-DEPENDS += " \
- python3-pbr-native \
- "
-
-RDEPENDS:${PN} += "\
- python3-doctest \
- python3-extras \
- python3-pbr \
- python3-six \
- "
-
-BBCLASSEXTEND = "nativesdk"
diff --git a/meta/recipes-devtools/python/python3-testtools_2.7.1.bb b/meta/recipes-devtools/python/python3-testtools_2.7.1.bb
index 79e46a02de..cc7e055632 100644
--- a/meta/recipes-devtools/python/python3-testtools_2.7.1.bb
+++ b/meta/recipes-devtools/python/python3-testtools_2.7.1.bb
@@ -1,3 +1,20 @@
-inherit setuptools3
-require python-testtools.inc
+SUMMARY = "Extensions to the Python standard library unit testing framework"
+HOMEPAGE = "https://pypi.org/project/testtools/"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e2c9d3e8ba7141c83bfef190e0b9379a"
+
+DEPENDS += "python3-hatch-vcs-native"
+
+inherit pypi python_hatchling
+
+SRC_URI[sha256sum] = "df6de96010e29ee21f637a147eabf30d50b25e3841dd1d68f93ee89ce77e366c"
+
+RDEPENDS:${PN} += "\
+ python3-doctest \
+ python3-extras \
+ python3-six \
+ "
+
+BBCLASSEXTEND = "nativesdk"