summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2018-02-01 20:01:53 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-06 10:54:40 +0000
commit6f1822e5f1eaafd8bc46e999de730c1fcca77f3a (patch)
treee3945e90923ee1db729d26313d04094bba16e44f /meta/recipes-devtools
parentc74bbe70988e7dd3ee1b7977de68a7ffe64fc8ef (diff)
downloadopenembedded-core-6f1822e5f1eaafd8bc46e999de730c1fcca77f3a.tar.gz
rpm: add a patch to help with Docker performance issues
Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools')
-rw-r--r--meta/recipes-devtools/rpm/files/0001-Revert-Set-FD_CLOEXEC-on-opened-files-before-exec-fr.patch49
-rw-r--r--meta/recipes-devtools/rpm/rpm_4.14.1.bb1
2 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rpm/files/0001-Revert-Set-FD_CLOEXEC-on-opened-files-before-exec-fr.patch b/meta/recipes-devtools/rpm/files/0001-Revert-Set-FD_CLOEXEC-on-opened-files-before-exec-fr.patch
new file mode 100644
index 0000000000..4651409a65
--- /dev/null
+++ b/meta/recipes-devtools/rpm/files/0001-Revert-Set-FD_CLOEXEC-on-opened-files-before-exec-fr.patch
@@ -0,0 +1,49 @@
+From 982e47df7b82c5ffe3c414cf5641f08dba0f0e64 Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Fri, 26 Jan 2018 16:32:04 +0200
+Subject: [PATCH] Revert "Set FD_CLOEXEC on opened files before exec from lua
+ script is called"
+
+This reverts commit 7a7c31f551ff167f8718aea6d5048f6288d60205.
+The reason is that when _SC_OPEN_MAX is much higher than the usual 1024
+(for example inside docker), the performance drops sharply.
+
+Upstream has been notified:
+https://bugzilla.redhat.com/show_bug.cgi?id=1537564
+
+Upstream-Status: Inappropriate [upstream needs to come up with a better fix]
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ luaext/lposix.c | 12 ------------
+ 1 file changed, 12 deletions(-)
+
+diff --git a/luaext/lposix.c b/luaext/lposix.c
+index 0a7c26c71..c578c5a11 100644
+--- a/luaext/lposix.c
++++ b/luaext/lposix.c
+@@ -335,22 +335,10 @@ static int Pexec(lua_State *L) /** exec(path,[args]) */
+ const char *path = luaL_checkstring(L, 1);
+ int i,n=lua_gettop(L);
+ char **argv;
+- int flag, fdno, open_max;
+
+ if (!have_forked)
+ return luaL_error(L, "exec not permitted in this context");
+
+- open_max = sysconf(_SC_OPEN_MAX);
+- if (open_max == -1) {
+- open_max = 1024;
+- }
+- for (fdno = 3; fdno < open_max; fdno++) {
+- flag = fcntl(fdno, F_GETFD);
+- if (flag == -1 || (flag & FD_CLOEXEC))
+- continue;
+- fcntl(fdno, F_SETFD, FD_CLOEXEC);
+- }
+-
+ argv = malloc((n+1)*sizeof(char*));
+ if (argv==NULL) return luaL_error(L,"not enough memory");
+ argv[0] = (char*)path;
+--
+2.15.1
+
diff --git a/meta/recipes-devtools/rpm/rpm_4.14.1.bb b/meta/recipes-devtools/rpm/rpm_4.14.1.bb
index d75902788e..7b8ea46a75 100644
--- a/meta/recipes-devtools/rpm/rpm_4.14.1.bb
+++ b/meta/recipes-devtools/rpm/rpm_4.14.1.bb
@@ -39,6 +39,7 @@ SRC_URI = "git://github.com/rpm-software-management/rpm;branch=rpm-4.14.x \
file://0003-rpmstrpool.c-make-operations-over-string-pools-threa.patch \
file://0004-build-pack.c-remove-static-local-variables-from-buil.patch \
file://0001-perl-disable-auto-reqs.patch \
+ file://0001-Revert-Set-FD_CLOEXEC-on-opened-files-before-exec-fr.patch \
"
PE = "1"