summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/syslinux
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-02-02 00:19:08 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-02-05 14:03:18 +0000
commita2b30108055e68b62fdad7319d7d569bc38a07b4 (patch)
tree5475574eefcdd545e4b9e3434ec42c374b5133d1 /meta/recipes-devtools/syslinux
parent1715d0907d372e787c054a5509690a2719acfed0 (diff)
downloadopenembedded-core-a2b30108055e68b62fdad7319d7d569bc38a07b4.tar.gz
syslinux: Disable error on implicit-function-declaration
syslinux has vendored copy of ext2fs/ext2_fs.h but uses ext2fs/ext2fs.h from e2fsprogs package, however, ext2fs/ext2fs.h has dependencies on ext2fs/ext2_fs.h coming from e2fsprogs package as these both headers come from same package, here syslinux uses ext2fs.h from e2fsprogs but supplies its own copy of ext2_fs.h which maybe out of sync and that results in warnings about implicit implicit-function-declarations e.g. recipe-sysroot/usr/include/ext2fs/ext2fs.h:727:16: error: implicit declaration of function 'ext2fs_has_feature_gdt_csum' [-Wimplicit-function-declaration] | 727 | ext2fs_has_feature_gdt_csum(fs->super); | | ^~~~~~~~~~~~~~~~~~~~~~~~~~~ ext2fs_has_feature_gdt_csum here comes from newer version of ext2fs/ext2_fs.h but missing from vendored copy, hence the warning. With gcc-14 this warning is treated as error by default, which breaks the build, so lets treat it as warning only. All these functions are never used in syslinux, so functionality-wise we are fine. Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/syslinux')
-rw-r--r--meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb b/meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb
index 332655bdf9..c8e7f25d2b 100644
--- a/meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb
+++ b/meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb
@@ -48,7 +48,7 @@ TARGET_LDFLAGS = ""
SECURITY_LDFLAGS = ""
LDFLAGS_SECTION_REMOVAL = ""
-CFLAGS:append = " -DNO_INLINE_FUNCS"
+CFLAGS:append = " -DNO_INLINE_FUNCS -Wno-error=implicit-function-declaration"
EXTRA_OEMAKE = " \
BINDIR=${bindir} SBINDIR=${sbindir} LIBDIR=${libdir} \