summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/qemuwrapper-cross_1.0.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-07 12:40:35 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-07 12:58:57 +0000
commit743d5233747d0a107490b31ea3da151ea1ace3ae (patch)
tree8225260e3404c0b5e6ba5aa0045896d450a69d00 /meta/recipes-devtools/qemu/qemuwrapper-cross_1.0.bb
parente43f8f917e4069d74b467dfd6aa29ff762e83a5e (diff)
downloadopenembedded-core-743d5233747d0a107490b31ea3da151ea1ace3ae.tar.gz
qemuwrapper: Don't use STAGING_BINDIR_CROSS directly
We need the files to be tracked by sstate so we need to jump through some hoops to ensure this happens. The cross bindir directory isn't staged automatically so we need to handle this outselves. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/qemu/qemuwrapper-cross_1.0.bb')
-rw-r--r--meta/recipes-devtools/qemu/qemuwrapper-cross_1.0.bb14
1 files changed, 10 insertions, 4 deletions
diff --git a/meta/recipes-devtools/qemu/qemuwrapper-cross_1.0.bb b/meta/recipes-devtools/qemu/qemuwrapper-cross_1.0.bb
index dc16047451..f23a7d7962 100644
--- a/meta/recipes-devtools/qemu/qemuwrapper-cross_1.0.bb
+++ b/meta/recipes-devtools/qemu/qemuwrapper-cross_1.0.bb
@@ -6,9 +6,15 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384
inherit qemu
do_install () {
- install -d ${STAGING_BINDIR_CROSS}
+ install -d ${D}${bindir_crossscripts}/
- echo "#!/bin/sh" > ${STAGING_BINDIR_CROSS}/qemuwrapper
- echo exec env ${@qemu_target_binary(d)} \"\$@\" >> ${STAGING_BINDIR_CROSS}/qemuwrapper
- chmod +x ${STAGING_BINDIR_CROSS}/qemuwrapper
+ echo "#!/bin/sh" > ${D}${bindir_crossscripts}/qemuwrapper
+ echo exec env ${@qemu_target_binary(d)} \"\$@\" >> ${D}${bindir_crossscripts}/qemuwrapper
+ chmod +x ${D}${bindir_crossscripts}/qemuwrapper
+}
+
+SYSROOT_PREPROCESS_FUNCS += "qemuwrapper_sysroot_preprocess"
+
+qemuwrapper_sysroot_preprocess () {
+ sysroot_stage_dir ${D}${bindir_crossscripts} ${SYSROOT_DESTDIR}${bindir_crossscripts}
}