summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pyyaml_6.0.1.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2024-02-08 18:18:56 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-02-10 14:12:54 +0000
commitdfde9526f9183907b2bc47fde4f59ab3a5848d90 (patch)
tree0d1fd7fda87554baf66b11eaa1cd465a7a68cba7 /meta/recipes-devtools/python/python3-pyyaml_6.0.1.bb
parente2b638dcd6b7c51f7ee2cd4bc051d6b12e642d6c (diff)
downloadopenembedded-core-dfde9526f9183907b2bc47fde4f59ab3a5848d90.tar.gz
python3-pyyaml: add PACKAGECONFIG for libyaml
For some time now, we have probably been susceptible to host contamination or at least non-deterministic behavior when libyaml was available in the build environment. The symptom is: ERROR: python3-pyyaml-6.0-r0 do_package_qa: QA Issue: /usr/lib/python3.11/site-packages/yaml/_yaml.cpython-311-aarch64-linux-gnu.so contained in package python3-pyyaml requires libyaml-0.so.2()(64bit), but no providers found in RDEPENDS:python3-pyyaml? [file-rdeps] >From the documentation: """ By default, the setup.py script checks whether LibYAML is installed and if so, builds and installs LibYAML bindings. To skip the check and force installation of LibYAML bindings, use the option --with-libyaml: python setup.py --with-libyaml install To disable the check and skip building and installing LibYAML bindings, use --without-libyaml: python setup.py --without-libyaml install """ Instead of leaving this to chance, add PACKAGECONFIG and by default build with the faster libyaml bindings. Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-pyyaml_6.0.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pyyaml_6.0.1.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pyyaml_6.0.1.bb b/meta/recipes-devtools/python/python3-pyyaml_6.0.1.bb
index 61f7cbc6b3..102e2f2498 100644
--- a/meta/recipes-devtools/python/python3-pyyaml_6.0.1.bb
+++ b/meta/recipes-devtools/python/python3-pyyaml_6.0.1.bb
@@ -12,6 +12,9 @@ inherit pypi python_setuptools_build_meta
SRC_URI += "file://0001-Fix-builds-with-Cython-3.patch"
SRC_URI[sha256sum] = "bfdf460b1736c775f2ba9f6a92bca30bc2095067b8a9d77876d1fad6cc3b4a43"
+PACKAGECONFIG ?= "libyaml"
+PACKAGECONFIG[libyaml] = "--with-libyaml,--without-libyaml,libyaml"
+
RDEPENDS:${PN} += "\
${PYTHON_PN}-datetime \
${PYTHON_PN}-netclient \