summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-cryptography-vectors_42.0.5.bb
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2024-02-28 08:25:31 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-02-29 10:25:12 +0000
commit83dad4a93ff81c6c1e048443e0827d825670158b (patch)
tree61e0a5701228f92a7f70057393a8e7ca4acd7eed /meta/recipes-devtools/python/python3-cryptography-vectors_42.0.5.bb
parent1048992c0d2a2bda3464185efdac5cc986a583d4 (diff)
downloadopenembedded-core-83dad4a93ff81c6c1e048443e0827d825670158b.tar.gz
python3-cryptography{-vectors}: upgrade to 42.0.5
* Includes an upgrade to pyo3 from 0.20.0 to 0.20.3 which fixes ppc64 * Refresh -crates.inc https://cryptography.io/en/latest/changelog/#v42-0-5 https://cryptography.io/en/latest/changelog/#v42-0-4 https://cryptography.io/en/latest/changelog/#v42-0-3 42.0.5 - 2024-02-23 * Limit the number of name constraint checks that will be performed in X.509 path validation to protect against denial of service attacks. * Upgrade pyo3 version, which fixes building on PowerPC. 42.0.4 - 2024-02-20 * Fixed a null-pointer-dereference and segfault that could occur when creating a PKCS#12 bundle. Credit to Alexander-Programming for reporting the issue. CVE-2024-26130 * Fixed ASN.1 encoding for PKCS7/SMIME signed messages. The fields SMIMECapabilities and SignatureAlgorithmIdentifier should now be correctly encoded according to the definitions in RFC 2633 RFC 3370. 42.0.3 - 2024-02-15 * Fixed an initialization issue that caused key loading failures for some users. CVE: CVE-2024-26130 https://nvd.nist.gov/vuln/detail/CVE-2024-26130 Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-cryptography-vectors_42.0.5.bb')
-rw-r--r--meta/recipes-devtools/python/python3-cryptography-vectors_42.0.5.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-cryptography-vectors_42.0.5.bb b/meta/recipes-devtools/python/python3-cryptography-vectors_42.0.5.bb
new file mode 100644
index 0000000000..ee522af08e
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-cryptography-vectors_42.0.5.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Test vectors for the cryptography package."
+HOMEPAGE = "https://cryptography.io/"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0 | BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4 \
+ file://LICENSE.APACHE;md5=4e168cce331e5c827d4c2b68a6200e1b \
+ file://LICENSE.BSD;md5=5ae30ba4123bc4f2fa49aa0b0dce887b"
+
+# NOTE: Make sure to keep this recipe at the same version as python3-cryptography
+# Upgrade both recipes at the same time
+
+SRC_URI[sha256sum] = "505cd5e3b0cb32da1526f07042b7fc38a4b6c356710cb73d2b5f76b037a38ed1"
+
+PYPI_PACKAGE = "cryptography_vectors"
+
+inherit pypi python_setuptools_build_meta
+
+DEPENDS += " \
+ python3-cryptography \
+"
+
+do_install:append () {
+ # Remove the sha256 checksum lines for pycache files
+ sed ${D}${PYTHON_SITEPACKAGES_DIR}/cryptography_vectors-${PV}.dist-info/RECORD -e '/__pycache__/d' -i
+}
+
+BBCLASSEXTEND = "native nativesdk"
+
+UPSTREAM_CHECK_REGEX = ""
+
+RECIPE_NO_UPDATE_REASON = "Must be updated in sync with python3-cryptography."