summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-click_8.1.7.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2024-02-19 16:07:55 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-02-20 11:38:15 +0000
commitb566b1e32c7993d1ab7795562f648e52ce186a70 (patch)
tree921f025e8db894d8edc26560c66783fa7c71eaa1 /meta/recipes-devtools/python/python3-click_8.1.7.bb
parentf5e6183b9557477bef74024a587de0bfcc2b7c0d (diff)
downloadopenembedded-core-b566b1e32c7993d1ab7795562f648e52ce186a70.tar.gz
python: Drop ${PYTHON_PN}
python 2 is gone and we don't need the abstraction now, drop the remaining usage of this variable. The definition in python3-dir.bbclass is left for now for other layers. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-click_8.1.7.bb')
-rw-r--r--meta/recipes-devtools/python/python3-click_8.1.7.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta/recipes-devtools/python/python3-click_8.1.7.bb b/meta/recipes-devtools/python/python3-click_8.1.7.bb
index a4ec6cd1ef..7d91e1af83 100644
--- a/meta/recipes-devtools/python/python3-click_8.1.7.bb
+++ b/meta/recipes-devtools/python/python3-click_8.1.7.bb
@@ -15,9 +15,9 @@ inherit pypi setuptools3 ptest
SRC_URI += "file://run-ptest"
RDEPENDS:${PN}-ptest += " \
- ${PYTHON_PN}-pytest \
- ${PYTHON_PN}-terminal \
- ${PYTHON_PN}-unixadmin \
+ python3-pytest \
+ python3-terminal \
+ python3-unixadmin \
"
do_install_ptest() {
@@ -32,8 +32,8 @@ UPSTREAM_CHECK_REGEX = "click/(?P<pver>\d+(\.\d+)+)/"
CLEANBROKEN = "1"
RDEPENDS:${PN} += "\
- ${PYTHON_PN}-io \
- ${PYTHON_PN}-threading \
+ python3-io \
+ python3-threading \
"
BBCLASSEXTEND = "native nativesdk"