summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-build_1.2.1.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-04-09 15:10:12 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-16 07:38:37 +0100
commit83227b767299a1f8bbeb9e3b69eab8aa09fb6a07 (patch)
tree651c223533ce48a181625e38d50fd7fc9b50baca /meta/recipes-devtools/python/python3-build_1.2.1.bb
parent12bd38ef2c26e60b3dd35b5227189699a4188c1d (diff)
downloadopenembedded-core-83227b767299a1f8bbeb9e3b69eab8aa09fb6a07.tar.gz
python3-build: upgrade 1.1.1 -> 1.2.1
Changelog: ============ -Avoid error when terminal width is undetectable on Python < 3.11 -Add --installer option, supporting pip and uv. Added uv extra. -Improve console output and provide -v for dependency installation -Avoid compiling unused bytecode when using pip -Dropped support for Python 3.7 Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-build_1.2.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-build_1.2.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-build_1.2.1.bb b/meta/recipes-devtools/python/python3-build_1.2.1.bb
new file mode 100644
index 0000000000..0156861201
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-build_1.2.1.bb
@@ -0,0 +1,32 @@
+SUMMARY = "A simple, correct PEP517 package builder"
+HOMEPAGE = "https://github.com/pypa/build"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=310439af287b0fb4780b2ad6907c256c"
+
+SRC_URI[sha256sum] = "526263f4870c26f26c433545579475377b2b7588b6f1eac76a001e873ae3e19d"
+
+inherit pypi python_flit_core
+
+DEPENDS += "python3-pyproject-hooks-native"
+
+DEPENDS:remove:class-native = "python3-build-native"
+
+# Skip dependencies as we're doing a minimal build to bootstrap
+PEP517_BUILD_OPTS:class-native = "--skip-dependency-check"
+
+do_compile:prepend:class-native() {
+ export PYTHONPATH="${S}/src"
+}
+
+RDEPENDS:${PN} += " \
+ python3-compression \
+ python3-difflib \
+ python3-ensurepip \
+ python3-logging \
+ python3-packaging \
+ python3-pyproject-hooks \
+ python3-tomllib \
+ python3-venv \
+"
+
+BBCLASSEXTEND = "native nativesdk"