summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl-cross/perlcross_1.4.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-06-06 14:01:23 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-06-07 21:11:57 +0100
commit99b2733e13f2fb5ef165d4e928b0a3d890b97ec0 (patch)
tree55aaffa4c0f9ae9c4a63dc2b9186792c72ff8cc0 /meta/recipes-devtools/perl-cross/perlcross_1.4.bb
parentf231bc2c28226776f0990ec65aa5f95e89021218 (diff)
downloadopenembedded-core-99b2733e13f2fb5ef165d4e928b0a3d890b97ec0.tar.gz
perl: update 5.34.1 -> 5.36.0
Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl-cross/perlcross_1.4.bb')
-rw-r--r--meta/recipes-devtools/perl-cross/perlcross_1.4.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl-cross/perlcross_1.4.bb b/meta/recipes-devtools/perl-cross/perlcross_1.4.bb
new file mode 100644
index 0000000000..1329306b0e
--- /dev/null
+++ b/meta/recipes-devtools/perl-cross/perlcross_1.4.bb
@@ -0,0 +1,38 @@
+SUMMARY = "Perl-cross build system"
+HOMEPAGE = "https://github.com/arsv/perl-cross"
+DESCRIPTION = "perl-cross provides configure script, top-level Makefile and some auxiliary files for perl, \
+with the primary emphasis on cross-compiling the source."
+SECTION = "devel"
+LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
+# README.md is taken from https://github.com/arsv/perl-cross/blob/master/README.md
+# but is not provided inside the release tarballs
+LIC_FILES_CHKSUM = "file://${WORKDIR}/README.md;md5=252fcce2026b765fee1ad74d2fb07a3b"
+
+inherit allarch
+
+SRC_URI = "https://github.com/arsv/perl-cross/releases/download/${PV}/perl-cross-${PV}.tar.gz;name=perl-cross \
+ file://README.md \
+ file://0001-perl-cross-add-LDFLAGS-when-linking-libperl.patch \
+ file://determinism.patch \
+ file://0001-Makefile-check-the-file-if-patched-or-not.patch \
+ "
+UPSTREAM_CHECK_URI = "https://github.com/arsv/perl-cross/releases/"
+
+SRC_URI[perl-cross.sha256sum] = "be9d9f9f7148edff7a2f9695ba3cb7e3975eff6b25a9a81dd311725fd757aa91"
+
+S = "${WORKDIR}/perl-cross-${PV}"
+
+do_configure () {
+}
+
+do_compile () {
+}
+
+do_install:class-native() {
+ mkdir -p ${D}/${datadir}/perl-cross/
+ cp -rf ${S}/* ${D}/${datadir}/perl-cross/
+ rm -rf ${D}/${datadir}/perl-cross/patches/
+}
+
+BBCLASSEXTEND = "native"
+