summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg
diff options
context:
space:
mode:
authorAlex Stewart <alex.stewart@ni.com>2024-02-08 13:10:08 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-02-09 13:54:12 +0000
commitc8405b86c6c3f9054810914105de5d70c4b7800b (patch)
treef9e8a74b79833953a9ce9e29ee44254dcb54ed32 /meta/recipes-devtools/opkg
parentcec2d4b32f7f1b24ecc358e2fc6e5fe6003274e5 (diff)
downloadopenembedded-core-c8405b86c6c3f9054810914105de5d70c4b7800b.tar.gz
opkg: add deprecation warning for internal solver
The opkg internal sat-solver is marked for deprecation in a future release. Add a recipe QA check to warn users who have the internal solver configured. Signed-off-by: Alex Stewart <alex.stewart@ni.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/opkg')
-rw-r--r--meta/recipes-devtools/opkg/opkg_0.6.3.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg/opkg_0.6.3.bb b/meta/recipes-devtools/opkg/opkg_0.6.3.bb
index 1f15c44e3e..9592ffc5d6 100644
--- a/meta/recipes-devtools/opkg/opkg_0.6.3.bb
+++ b/meta/recipes-devtools/opkg/opkg_0.6.3.bb
@@ -61,6 +61,15 @@ do_install_ptest () {
sed -i -e '/@PYTHONPATH=. $(PYTHON) $^/a\\t@if [ "$$?" != "0" ];then echo "FAIL:"$^;else echo "PASS:"$^;fi' ${D}${PTEST_PATH}/tests/Makefile
}
+WARN_QA:append = " internal-solver-deprecation"
+QARECIPETEST[internal-solver-deprecation] = "qa_check_solver_deprecation"
+def qa_check_solver_deprecation (pn, d, messages):
+ pkgconfig = (d.getVar("PACKAGECONFIG") or "").split()
+
+ if "libsolv" not in pkgconfig:
+ oe.qa.handle_error("internal-solver-deprecation", "The opkg internal solver will be deprecated in future opkg releases. Consider enabling \"libsolv\" in PACKAGECONFIG.", d)
+
+
RDEPENDS:${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-arch-config libarchive"
RDEPENDS:${PN}:class-native = ""
RDEPENDS:${PN}:class-nativesdk = ""