summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gdb/gdb_13.1.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-02-22 16:38:30 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-02-24 11:03:45 +0000
commit87a8c2af735e06338463414a2cbcd3224b9ea112 (patch)
tree7449bdcfc4a55d120839cc6a482c920127ee20bb /meta/recipes-devtools/gdb/gdb_13.1.bb
parent65b1e199dcaabf93bae33e06727bb1238b703d83 (diff)
downloadopenembedded-core-87a8c2af735e06338463414a2cbcd3224b9ea112.tar.gz
gdb: Upgrade to 13.1
Add patch to fix typo for build on musl GDB 13.1 includes the following changes and enhancements: * Support for the following new targets has been added in both GDB and GDBserver: ** GNU/Linux/LoongArch (gdbserver) loongarch*-*-linux* ** GNU/Linux/CSKY (gdbserver) csky*-*linux* * The Windows native target now supports target async. * FreeBSD: ** Arm and AArch64: Support for Thread Local Storage (TLS) variables ** Hardware watchpoint support on AArch64 FreeBSD * Floating-point support has now been added on LoongArch GNU/Linux. * New commands: ** set print nibbles [on|off] show print nibbles This controls whether the 'print/t' command will display binary values in groups of four bits, known as "nibbles". The default is 'off'. ** Various styling-related commands. See the gdb/NEWS file for more details (see link at the bottom). ** Various maintenance commands. These are normally aimed at GDB experts or developers. See the gdb/NEWS file for more details (see link at the bottom). * Python API improvements: ** New Python API for instruction disassembly. The new attribute 'locations' of gdb.Breakpoint returns a list of gdb.BreakpointLocation objects specifying the locations where the breakpoint is inserted into the debuggee. ** New Python type gdb.BreakpointLocation. ** New function gdb.format_address(ADDRESS, PROGSPACE, ARCHITECTURE) that formats ADDRESS as 'address <symbol+offset>' ** New function gdb.current_language that returns the name of the current language. Unlike gdb.parameter('language'), this will never return 'auto'. ** New function gdb.print_options that returns a dictionary of the prevailing print options, in the form accepted by gdb.Value.format_string. ** New method gdb.Frame.language that returns the name of the frame's language. ** gdb.Value.format_string now uses the format provided by 'print', if it is called during a 'print' or other similar operation. ** gdb.Value.format_string now accepts the 'summary' keyword. This can be used to request a shorter representation of a value, the way that 'set print frame-arguments scalars' does. ** The gdb.register_window_type method now restricts the set of acceptable window names. The first character of a window's name must start with a character in the set [a-zA-Z], every subsequent character of a window's name must be in the set [-_.a-zA-Z0-9]. * GDB/MI changes: ** MI version 1 is deprecated, and will be removed in GDB 14. ** The async record stating the stopped reason 'breakpoint-hit' now contains an optional field locno. * Miscellaneous improvements: ** gdb now supports zstd compressed debug sections (ELFCOMPRESS_ZSTD) for ELF. ** New convenience variable $_inferior_thread_count contains the number of live threads in the current inferior. ** New convenience variables $_hit_bpnum and $_hit_locno, set to the breakpoint number and the breakpoint location number of the breakpoint last hit. ** The "info breakpoints" now displays enabled breakpoint locations of disabled breakpoints as in the "y-" state. ** The format of 'disassemble /r' and 'record instruction-history /r' has changed to match the layout of GNU objdump when disassembling. A new format "/b" has been introduce to provide the old behavior of "/r". ** The TUI no longer styles the source and assembly code highlighted by the current position indicator by default. You can however re-enable styling using the new "set style tui-current-position" command. ** It is now possible to use the "document" command to document user-defined commands. ** Support for memory tag data for AArch64 MTE. * Support Removal notices: ** DBX mode has been removed. ** Support for building against Python version 2 has been removed. It is now only possible to build GDB against Python 3. ** Support for the following commands has been removed: set debug aix-solib on|off show debug aix-solib set debug solib-frv on|off show debug solib-frv Use the "set/show debug solib" commands instead. For a complete list and more details on each item, please see the gdb/NEWS file, available at [1]: [1] https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;a=blob_plain;f=gdb/NEWS;hb=gdb-13.1-release Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/gdb/gdb_13.1.bb')
-rw-r--r--meta/recipes-devtools/gdb/gdb_13.1.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gdb/gdb_13.1.bb b/meta/recipes-devtools/gdb/gdb_13.1.bb
new file mode 100644
index 0000000000..9c6db4ca2c
--- /dev/null
+++ b/meta/recipes-devtools/gdb/gdb_13.1.bb
@@ -0,0 +1,39 @@
+require gdb-common.inc
+
+inherit gettext pkgconfig
+
+#LDFLAGS:append = " -s"
+#export CFLAGS:append=" -L${STAGING_LIBDIR}"
+
+# cross-canadian must not see this
+PACKAGES =+ "gdbserver"
+FILES:gdbserver = "${bindir}/gdbserver"
+
+require gdb.inc
+
+inherit python3-dir
+
+EXTRA_OEMAKE:append:libc-musl = "\
+ gt_cv_func_gnugettext1_libc=yes \
+ gt_cv_func_gnugettext2_libc=yes \
+ gl_cv_func_working_strerror=yes \
+ gl_cv_func_strerror_0_works=yes \
+ gl_cv_func_gettimeofday_clobber=no \
+ "
+
+do_configure:prepend() {
+ if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
+ cat > ${WORKDIR}/python << EOF
+#!/bin/sh
+case "\$2" in
+ --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}/" ;;
+ --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}${PYTHON_ABI}" ;;
+ --exec-prefix) echo "${exec_prefix}" ;;
+ *) exit 1 ;;
+esac
+exit 0
+EOF
+ chmod +x ${WORKDIR}/python
+ fi
+}
+