summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/dnf
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2017-08-04 14:14:02 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-20 22:31:13 +0000
commit3328211afdef8ffb00dd4dff1143959d5412b075 (patch)
tree4903b2b0ed8c09605baf9c546eac47fa0617d83a /meta/recipes-devtools/dnf
parentc47b54aeae5daabb458d6f7118a16257021c1822 (diff)
downloadopenembedded-core-3328211afdef8ffb00dd4dff1143959d5412b075.tar.gz
python: fix RDEPENDS on several recipes, due to non-existent packages
The packaging has been altered slightly so ensure the dependencies are all still valid. Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-devtools/dnf')
-rw-r--r--meta/recipes-devtools/dnf/dnf_2.7.5.bb26
1 files changed, 24 insertions, 2 deletions
diff --git a/meta/recipes-devtools/dnf/dnf_2.7.5.bb b/meta/recipes-devtools/dnf/dnf_2.7.5.bb
index fbd3bd4571..b88ddb445a 100644
--- a/meta/recipes-devtools/dnf/dnf_2.7.5.bb
+++ b/meta/recipes-devtools/dnf/dnf_2.7.5.bb
@@ -25,8 +25,30 @@ DEPENDS += "libdnf librepo libcomps python3-iniparse"
EXTRA_OECMAKE = " -DWITH_MAN=0 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3"
BBCLASSEXTEND = "native nativesdk"
-RDEPENDS_${PN}_class-target += "python3-core python3-codecs python3-netclient python3-email python3-threading python3-distutils librepo python3-shell python3-subprocess libcomps libdnf python3-sqlite3 python3-compression python3-rpm python3-iniparse python3-json python3-importlib python3-curses python3-argparse python3-misc python3-gpg"
-# Recommend gnupg so that GPG signature check on repository metadata is possible
+
+RDEPENDS_${PN}_class-target += " \
+ python3-core \
+ python3-codecs \
+ python3-netclient \
+ python3-email \
+ python3-threading \
+ python3-distutils \
+ python3-logging \
+ python3-fcntl \
+ librepo \
+ python3-shell \
+ libcomps \
+ libdnf \
+ python3-sqlite3 \
+ python3-compression \
+ python3-rpm \
+ python3-iniparse \
+ python3-json \
+ python3-curses \
+ python3-misc \
+ python3-gpg \
+ "
+
RRECOMMENDS_${PN}_class-target += "gnupg"
# Create a symlink called 'dnf' as 'make install' does not do it, but