summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb
diff options
context:
space:
mode:
authorHarald Seiler <hws@denx.de>2023-02-03 10:59:51 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-02-07 21:54:22 +0000
commit7031bc65b10040877392ed774a0cdddef85c12e0 (patch)
tree99ad859d28b9234589819ce0237ef8c71f461064 /meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb
parent8f5af6de0d4e72d4efa5be8f85de62214acf4ae8 (diff)
downloadopenembedded-core-7031bc65b10040877392ed774a0cdddef85c12e0.tar.gz
bootchart2: Fix usrmerge support
bootchart2 introduced a variable EARLY_PREFIX for supporting systems with usrmerge [1]. Right now, the recipe here is sidestepping this feature and trying to replicate it by overwriting other variables and even patching the sources. This wasn't enough, however, as there are still problems: For example, some setup code in the bootchart-collector fails because it expects EARLY_PREFIX to be used [2]. Cleanup the recipe to set EARLY_PREFIX and remove the other workarounds. [1]: https://github.com/xrmx/bootchart/commit/56a638ace1d172163b6d636c89892446b8add4b6 [2]: https://github.com/xrmx/bootchart/blob/3d2136d0335718fbe1a8e2370ccbc30123a6e593/collector/collector.c#L670-L672 Fixes: 4157600d3122 ("bootchart2: switch to add patch from change source in do_install") Signed-off-by: Harald Seiler <hws@denx.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb')
-rw-r--r--meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb11
1 files changed, 4 insertions, 7 deletions
diff --git a/meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb b/meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb
index b4d5b7cd9b..297dbfb578 100644
--- a/meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb
+++ b/meta/recipes-devtools/bootchart2/bootchart2_0.14.9.bb
@@ -93,7 +93,6 @@ UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+\.\d+(\.\d+)*)"
SRC_URI = "git://github.com/xrmx/bootchart.git;branch=master;protocol=https \
file://bootchartd_stop.sh \
file://0001-collector-Allocate-space-on-heap-for-chunks.patch \
- file://0001-bootchart2-support-usrmerge.patch \
file://0001-bootchartd.in-make-sure-only-one-bootchartd-process.patch \
file://0001-Do-not-include-linux-fs.h.patch \
"
@@ -120,12 +119,11 @@ UPDATERCPN = "bootchartd-stop-initscript"
INITSCRIPT_NAME = "bootchartd_stop.sh"
INITSCRIPT_PARAMS = "start 99 2 3 4 5 ."
-EXTRA_OEMAKE = 'BASE_SBINDIR="${base_sbindir}"'
-
do_compile:prepend () {
export PY_LIBDIR="${libdir}/${PYTHON_DIR}"
export BINDIR="${bindir}"
- export LIBDIR="${base_libdir}"
+ export LIBDIR="/${baselib}"
+ export EARLY_PREFIX="${root_prefix}"
}
do_install () {
@@ -133,9 +131,8 @@ do_install () {
export PY_LIBDIR="${libdir}/${PYTHON_DIR}"
export BINDIR="${bindir}"
export DESTDIR="${D}"
- export LIBDIR="${base_libdir}"
- export PKGLIBDIR="${base_libdir}/bootchart"
- export SYSTEMD_UNIT_DIR="${systemd_system_unitdir}"
+ export LIBDIR="/${baselib}"
+ export EARLY_PREFIX="${root_prefix}"
oe_runmake install NO_PYTHON_COMPILE=1
install -d ${D}${sysconfdir}/init.d