summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/autoconf
diff options
context:
space:
mode:
authorConstantin Musca <constantinx.musca@intel.com>2012-09-07 11:22:16 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-10 12:08:23 +0100
commit16d1c8f076378d0878f332f83b7e1f5fcf16447d (patch)
treef63cf3bf63661446e294996b49307219bf5e4463 /meta/recipes-devtools/autoconf
parent1a4b277e47a8d624cde4c73713d036e230f3a523 (diff)
downloadopenembedded-core-16d1c8f076378d0878f332f83b7e1f5fcf16447d.tar.gz
autoconf: use --warning=cross only if supported
Adapt autoconf to pass --warning=cross to automake only if supported. [YOCTO #842] Signed-off-by: Constantin Musca <constantinx.musca@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/autoconf')
-rw-r--r--meta/recipes-devtools/autoconf/autoconf/check-automake-cross-warning.patch34
-rw-r--r--meta/recipes-devtools/autoconf/autoconf_2.69.bb3
2 files changed, 36 insertions, 1 deletions
diff --git a/meta/recipes-devtools/autoconf/autoconf/check-automake-cross-warning.patch b/meta/recipes-devtools/autoconf/autoconf/check-automake-cross-warning.patch
new file mode 100644
index 0000000000..73394d7d52
--- /dev/null
+++ b/meta/recipes-devtools/autoconf/autoconf/check-automake-cross-warning.patch
@@ -0,0 +1,34 @@
+Use --warning=cross only if supported by automake
+
+Upstream-Status: Inappropriate [configuration]
+
+Signed-off-by: Constantin Musca <constantinx.musca@intel.com>
+
+--- a/bin/autoreconf.in
++++ b/bin/autoreconf.in
+@@ -127,6 +127,8 @@ my $aclocal_supports_warnings = 0;
+ my $automake_supports_force_missing = 0;
+ # Does automake support -Wfoo?
+ my $automake_supports_warnings = 0;
++# Does automake support --warning=cross
++my $automake_supports_cross_warning = 0;
+
+ my @prepend_include;
+ my @include;
+@@ -191,6 +193,7 @@ sub parse_args ()
+ $aclocal_supports_warnings = $aclocal_help =~ /--warnings/;
+ $automake_supports_force_missing = $automake_help =~ /--force-missing/;
+ $automake_supports_warnings = $automake_help =~ /--warnings/;
++ $automake_supports_cross_warning = $automake_help =~ /cross/;
+
+ # Dispatch autoreconf's option to the tools.
+ # --include;
+@@ -244,6 +247,8 @@ sub parse_args ()
+ $libtoolize .= ' --debug';
+ }
+ # --warnings;
++ @warning = grep { $_ ne "cross" } @warning
++ if ! $automake_supports_cross_warning;
+ if (@warning)
+ {
+ my $warn = ' --warnings=' . join (',', @warning);
diff --git a/meta/recipes-devtools/autoconf/autoconf_2.69.bb b/meta/recipes-devtools/autoconf/autoconf_2.69.bb
index 478f8eddbc..1ec1cb52af 100644
--- a/meta/recipes-devtools/autoconf/autoconf_2.69.bb
+++ b/meta/recipes-devtools/autoconf/autoconf_2.69.bb
@@ -1,6 +1,6 @@
require autoconf.inc
-PR = "r7"
+PR = "r8"
PARALLEL_MAKE = ""
@@ -8,6 +8,7 @@ LICENSE = "GPLv2 & GPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
file://COPYINGv3;md5=d32239bcb673463ab874e80d47fae504"
SRC_URI += "file://autoreconf-include.patch \
+ file://check-automake-cross-warning.patch \
file://autoreconf-exclude.patch \
file://autoreconf-foreign.patch \
file://autoreconf-gnuconfigize.patch \