summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/apt
diff options
context:
space:
mode:
authorSudip Mukherjee <sudipm.mukherjee@gmail.com>2023-05-02 15:00:55 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-05-05 11:07:21 +0100
commit2e42fb105e474b5ab25f2d2ded55124838b39e8d (patch)
tree9ff864b90a97cae93b6d5b8ead5e218a0cca476f /meta/recipes-devtools/apt
parentdc85b747af14f5262590e72e55d2c49670cf09a7 (diff)
downloadopenembedded-core-2e42fb105e474b5ab25f2d2ded55124838b39e8d.tar.gz
apt: Upgrade to v2.6.0
Changes: Rebase patches for upstream changes Remove upstream applied patches Update homepage Update sha256sum for new version Signed-off-by: Sudip Mukherjee <sudipm.mukherjee@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/apt')
-rw-r--r--meta/recipes-devtools/apt/apt/0001-Disable-documentation-directory-altogether.patch6
-rw-r--r--meta/recipes-devtools/apt/apt/0001-Remove-using-std-binary_function.patch8
-rw-r--r--meta/recipes-devtools/apt/apt/0001-add-missing-cstdint-for-uint16_t.patch35
-rw-r--r--meta/recipes-devtools/apt/apt/0001-cmake-Do-not-build-po-files.patch9
-rw-r--r--meta/recipes-devtools/apt/apt/0001-typecast-time_t-and-suseconds_t-from-std-chrono.patch64
-rw-r--r--meta/recipes-devtools/apt/apt/0002-interactive-helper-Undefine-_FORTIFY_SOURCE.patch27
-rw-r--r--meta/recipes-devtools/apt/apt_2.6.0.bb (renamed from meta/recipes-devtools/apt/apt_2.4.5.bb)7
7 files changed, 13 insertions, 143 deletions
diff --git a/meta/recipes-devtools/apt/apt/0001-Disable-documentation-directory-altogether.patch b/meta/recipes-devtools/apt/apt/0001-Disable-documentation-directory-altogether.patch
index 8b28ede8a8..5443ff6caa 100644
--- a/meta/recipes-devtools/apt/apt/0001-Disable-documentation-directory-altogether.patch
+++ b/meta/recipes-devtools/apt/apt/0001-Disable-documentation-directory-altogether.patch
@@ -13,11 +13,11 @@ Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 9745c13..7cfc9ee 100644
+index 668e2d762..62f441bfa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -239,7 +239,7 @@ add_subdirectory(apt-pkg)
- add_subdirectory(apt-private)
+@@ -246,7 +246,7 @@ add_subdirectory(apt-private)
+ endif()
add_subdirectory(cmdline)
add_subdirectory(completions)
-add_subdirectory(doc)
diff --git a/meta/recipes-devtools/apt/apt/0001-Remove-using-std-binary_function.patch b/meta/recipes-devtools/apt/apt/0001-Remove-using-std-binary_function.patch
index 3065210a04..15b036b90d 100644
--- a/meta/recipes-devtools/apt/apt/0001-Remove-using-std-binary_function.patch
+++ b/meta/recipes-devtools/apt/apt/0001-Remove-using-std-binary_function.patch
@@ -14,7 +14,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
1 file changed, 10 insertions(+), 23 deletions(-)
diff --git a/ftparchive/apt-ftparchive.cc b/ftparchive/apt-ftparchive.cc
-index 87ce9153c..56fdc2246 100644
+index 0f6587281..0a253b12b 100644
--- a/ftparchive/apt-ftparchive.cc
+++ b/ftparchive/apt-ftparchive.cc
@@ -48,6 +48,11 @@
@@ -33,19 +33,19 @@ index 87ce9153c..56fdc2246 100644
bool SrcDone;
time_t ContentsMTime;
-- struct ContentsCompare : public binary_function<PackageMap,PackageMap,bool>
+- struct ContentsCompare
- {
- inline bool operator() (const PackageMap &x,const PackageMap &y)
- {return x.ContentsMTime < y.ContentsMTime;};
- };
-
-- struct DBCompare : public binary_function<PackageMap,PackageMap,bool>
+- struct DBCompare
- {
- inline bool operator() (const PackageMap &x,const PackageMap &y)
- {return x.BinCacheDB < y.BinCacheDB;};
- };
-
-- struct SrcDBCompare : public binary_function<PackageMap,PackageMap,bool>
+- struct SrcDBCompare
- {
- inline bool operator() (const PackageMap &x,const PackageMap &y)
- {return x.SrcCacheDB < y.SrcCacheDB;};
diff --git a/meta/recipes-devtools/apt/apt/0001-add-missing-cstdint-for-uint16_t.patch b/meta/recipes-devtools/apt/apt/0001-add-missing-cstdint-for-uint16_t.patch
deleted file mode 100644
index 44aa8a5873..0000000000
--- a/meta/recipes-devtools/apt/apt/0001-add-missing-cstdint-for-uint16_t.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 960d10e89cf60d39998dae6fdcd4f0866b753a79 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Mon, 23 Jan 2023 12:31:35 -0800
-Subject: [PATCH] add missing <cstdint> for uint16_t
-
-This fixes build problems with gcc 13 snapshot [1]
-
-Fixes
-| include/apt-pkg/pkgcache.h:257:23: warning: cast from 'char*' to 'const uint16_t*' {aka 'const short unsigned int*'} increases required alignment of target type [-Wcast-align]
-| 257 | uint16_t len = *reinterpret_cast<const uint16_t*>(name - sizeof(uint16_t));
-| | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-
-[1] https://www.gnu.org/software/gcc/gcc-13/porting_to.html
-
-Upstream-Status: Submitted [https://salsa.debian.org/apt-team/apt/-/merge_requests/276]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- apt-pkg/contrib/mmap.cc | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/apt-pkg/contrib/mmap.cc b/apt-pkg/contrib/mmap.cc
-index 642e20473..0568e1cd0 100644
---- a/apt-pkg/contrib/mmap.cc
-+++ b/apt-pkg/contrib/mmap.cc
-@@ -23,6 +23,7 @@
- #include <apt-pkg/macros.h>
- #include <apt-pkg/mmap.h>
-
-+#include <cstdint>
- #include <cstring>
- #include <string>
- #include <errno.h>
---
-2.39.1
-
diff --git a/meta/recipes-devtools/apt/apt/0001-cmake-Do-not-build-po-files.patch b/meta/recipes-devtools/apt/apt/0001-cmake-Do-not-build-po-files.patch
index 2837b7f1b3..036ce35963 100644
--- a/meta/recipes-devtools/apt/apt/0001-cmake-Do-not-build-po-files.patch
+++ b/meta/recipes-devtools/apt/apt/0001-cmake-Do-not-build-po-files.patch
@@ -15,16 +15,18 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
1 file changed, 7 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 3c8ec3f..821a24f 100644
+index be157a55f..54163ae6c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -245,13 +245,6 @@ add_subdirectory(ftparchive)
+@@ -252,15 +252,6 @@ add_subdirectory(ftparchive)
add_subdirectory(methods)
add_subdirectory(test)
-if (USE_NLS)
-add_subdirectory(po)
+-endif()
-
+-if(TARGET update-po AND TARGET update-po4a)
-# Link update-po4a into the update-po target
-add_dependencies(update-po update-po4a)
-endif()
@@ -32,6 +34,3 @@ index 3c8ec3f..821a24f 100644
# Create our directories.
install_empty_directories(
${CONF_DIR}/apt.conf.d
---
-2.31.0
-
diff --git a/meta/recipes-devtools/apt/apt/0001-typecast-time_t-and-suseconds_t-from-std-chrono.patch b/meta/recipes-devtools/apt/apt/0001-typecast-time_t-and-suseconds_t-from-std-chrono.patch
deleted file mode 100644
index fc3509d336..0000000000
--- a/meta/recipes-devtools/apt/apt/0001-typecast-time_t-and-suseconds_t-from-std-chrono.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-From b7a1a4d3259557f2587f7d5d47502691d94c21c2 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Fri, 16 Sep 2022 20:00:30 -0700
-Subject: [PATCH 1/2] typecast time_t and suseconds_t from std::chrono
-
-This fixes build on some architectures like mips
-progress.cc:125:31: error: non-constant-expression cannot be narrowed from type 'std::chrono::duration<long long>::rep' (aka 'long long') to '__time_t' (aka 'long') in initializer list [-Wc++11-narrowing]
- struct timeval NowTime = { Now_sec.count(), Now_usec.count() };
-
-Upstream-Status: Submitted [https://salsa.debian.org/apt-team/apt/-/merge_requests/259]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- apt-pkg/acquire.cc | 4 ++--
- apt-pkg/contrib/progress.cc | 2 +-
- ftparchive/apt-ftparchive.cc | 2 +-
- 3 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/apt-pkg/acquire.cc b/apt-pkg/acquire.cc
-index 100ccde..dd0624a 100644
---- a/apt-pkg/acquire.cc
-+++ b/apt-pkg/acquire.cc
-@@ -53,11 +53,11 @@
- using namespace std;
-
- // helper to convert time_point to a timeval
--static struct timeval SteadyDurationToTimeVal(std::chrono::steady_clock::duration Time)
-+constexpr struct timeval SteadyDurationToTimeVal(std::chrono::steady_clock::duration Time)
- {
- auto const Time_sec = std::chrono::duration_cast<std::chrono::seconds>(Time);
- auto const Time_usec = std::chrono::duration_cast<std::chrono::microseconds>(Time - Time_sec);
-- return {Time_sec.count(), Time_usec.count()};
-+ return timeval{static_cast<time_t>(Time_sec.count()), static_cast<suseconds_t>(Time_usec.count())};
- }
-
- std::string pkgAcquire::URIEncode(std::string const &part) /*{{{*/
-diff --git a/apt-pkg/contrib/progress.cc b/apt-pkg/contrib/progress.cc
-index 03f88d4..eb688b9 100644
---- a/apt-pkg/contrib/progress.cc
-+++ b/apt-pkg/contrib/progress.cc
-@@ -122,7 +122,7 @@ bool OpProgress::CheckChange(float Interval)
- auto const Now = std::chrono::steady_clock::now().time_since_epoch();
- auto const Now_sec = std::chrono::duration_cast<std::chrono::seconds>(Now);
- auto const Now_usec = std::chrono::duration_cast<std::chrono::microseconds>(Now - Now_sec);
-- struct timeval NowTime = { Now_sec.count(), Now_usec.count() };
-+ struct timeval NowTime = { static_cast<time_t>(Now_sec.count()), static_cast<suseconds_t>(Now_usec.count()) };
-
- std::chrono::duration<decltype(Interval)> Delta =
- std::chrono::seconds(NowTime.tv_sec - LastTime.tv_sec) +
-diff --git a/ftparchive/apt-ftparchive.cc b/ftparchive/apt-ftparchive.cc
-index 56fdc22..0a253b1 100644
---- a/ftparchive/apt-ftparchive.cc
-+++ b/ftparchive/apt-ftparchive.cc
-@@ -58,7 +58,7 @@ static struct timeval GetTimevalFromSteadyClock() /*{{{*/
- auto const Time = std::chrono::steady_clock::now().time_since_epoch();
- auto const Time_sec = std::chrono::duration_cast<std::chrono::seconds>(Time);
- auto const Time_usec = std::chrono::duration_cast<std::chrono::microseconds>(Time - Time_sec);
-- return { Time_sec.count(), Time_usec.count() };
-+ return { static_cast<time_t>(Time_sec.count()), static_cast<suseconds_t>(Time_usec.count()) };
- }
- /*}}}*/
- static auto GetTimeDeltaSince(struct timeval StartTime) /*{{{*/
---
-2.37.3
-
diff --git a/meta/recipes-devtools/apt/apt/0002-interactive-helper-Undefine-_FORTIFY_SOURCE.patch b/meta/recipes-devtools/apt/apt/0002-interactive-helper-Undefine-_FORTIFY_SOURCE.patch
deleted file mode 100644
index 18c4641b22..0000000000
--- a/meta/recipes-devtools/apt/apt/0002-interactive-helper-Undefine-_FORTIFY_SOURCE.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 891076c2cf4298b5d587545497f4831f0d21caa1 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Fri, 16 Sep 2022 20:04:43 -0700
-Subject: [PATCH 2/2] interactive-helper: Undefine _FORTIFY_SOURCE
-
-This ensures that it compiles when clang compiler is passing
--DFORTIFY_SOURCES=2
-
-Upstream-Status: Submitted [https://salsa.debian.org/apt-team/apt/-/merge_requests/259]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- test/interactive-helper/libnoprofile.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/test/interactive-helper/libnoprofile.c b/test/interactive-helper/libnoprofile.c
-index f11b898..b26ec2a 100644
---- a/test/interactive-helper/libnoprofile.c
-+++ b/test/interactive-helper/libnoprofile.c
-@@ -1,4 +1,5 @@
- #define _GNU_SOURCE
-+#undef _FORTIFY_SOURCE
- #include <stdarg.h>
- #include <stdlib.h>
- #include <string.h>
---
-2.37.3
-
diff --git a/meta/recipes-devtools/apt/apt_2.4.5.bb b/meta/recipes-devtools/apt/apt_2.6.0.bb
index 429cf6e659..b872be8371 100644
--- a/meta/recipes-devtools/apt/apt_2.4.5.bb
+++ b/meta/recipes-devtools/apt/apt_2.6.0.bb
@@ -1,6 +1,6 @@
SUMMARY = "Advanced front-end for dpkg"
DESCRIPTION = "APT is the Advanced Package Tool, an advanced interface to the Debian packaging system which provides the apt-get program."
-HOMEPAGE = "https://packages.debian.org/jessie/apt"
+HOMEPAGE = "https://packages.debian.org/sid/apt"
LICENSE = "GPL-2.0-or-later"
SECTION = "base"
@@ -14,9 +14,6 @@ SRC_URI = "${DEBIAN_MIRROR}/main/a/apt/${BPN}_${PV}.tar.xz \
file://0001-Hide-fstatat64-and-prlimit64-defines-on-musl.patch \
file://0001-aptwebserver.cc-Include-array.patch \
file://0001-Remove-using-std-binary_function.patch \
- file://0001-typecast-time_t-and-suseconds_t-from-std-chrono.patch \
- file://0002-interactive-helper-Undefine-_FORTIFY_SOURCE.patch \
- file://0001-add-missing-cstdint-for-uint16_t.patch \
"
SRC_URI:append:class-native = " \
@@ -29,7 +26,7 @@ SRC_URI:append:class-nativesdk = " \
file://0001-Revert-always-run-dpkg-configure-a-at-the-end-of-our.patch \
"
-SRC_URI[sha256sum] = "5552f175c3a3924f5cda0c079b821b30f68a2521959f2c30ab164d2ec7993ecf"
+SRC_URI[sha256sum] = "43467d1ca7de6c0955fd991925433e22fa66230870e5f66c4498675d01776c2a"
LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263"
# the package is taken from snapshots.debian.org; that source is static and goes stale