summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-03-07 11:10:36 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-03-08 08:06:14 +0000
commite017f405bf6ae6c269a8c9c981878fd1ad8666b6 (patch)
tree523a55ed4c7fd02e4724ed821a05b88634dbffd0 /meta/recipes-core
parentfba4ac04524c5c3fa04a51b6e0679276327115ad (diff)
downloadopenembedded-core-e017f405bf6ae6c269a8c9c981878fd1ad8666b6.tar.gz
systemd: Check for directory before chmod'ing it
da9db878a15 systemd: fix dead link /var/log/README add -Dcreate-log-dirs=false which means journal dir will not be generated regardless of VOLATILE_LOG_DIR value if a distro decided to set VOLATILE_LOG_DIR=no this code path will be executes and the directory being operated upon wont exist ending in do_install errors chown: cannot access '/mnt/b/yoe/master/build/tmp/work/riscv64-yoe-linux/systemd/255.4/image/var/log/journal': No such file or directory Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Changqing Li <changqing.li@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/systemd/systemd_255.4.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/systemd/systemd_255.4.bb b/meta/recipes-core/systemd/systemd_255.4.bb
index d59ca30c12..bcef3e6b7a 100644
--- a/meta/recipes-core/systemd/systemd_255.4.bb
+++ b/meta/recipes-core/systemd/systemd_255.4.bb
@@ -306,7 +306,7 @@ do_install() {
# /var/log is typically a symbolic link to inside /var/volatile,
# which is expected to be empty.
rm -rf ${D}${localstatedir}/log
- else
+ elif [ -e ${D}${localstatedir}/log/journal ]; then
chown root:systemd-journal ${D}${localstatedir}/log/journal
# journal-remote creates this at start