summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2024-03-05 22:54:43 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-04 14:02:24 +0100
commit7d11e4d55c9de23edbf5ba21d7ee007bab20c38a (patch)
tree57c61bed4412b48440ec93863413b64a53e45e04 /meta/recipes-core
parent8cfc94a4404c54bc73eab9f98d9da1f84c2135ad (diff)
downloadopenembedded-core-7d11e4d55c9de23edbf5ba21d7ee007bab20c38a.tar.gz
ovmf: set CVE_PRODUCT and CVE_VERSION
Set CVE_PRODUCT and CVE_VERSION for ovmf. NVD uses 'edk2' and the version should be the date only. Here's an example: https://nvd.nist.gov/vuln/detail/CVE-2023-45232 Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/ovmf/ovmf_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-core/ovmf/ovmf_git.bb b/meta/recipes-core/ovmf/ovmf_git.bb
index 3dc031d3b6..5b1353b8e8 100644
--- a/meta/recipes-core/ovmf/ovmf_git.bb
+++ b/meta/recipes-core/ovmf/ovmf_git.bb
@@ -30,6 +30,9 @@ PV = "edk2-stable202308"
SRCREV = "819cfc6b42a68790a23509e4fcc58ceb70e1965e"
UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>edk2-stable.*)"
+CVE_PRODUCT = "edk2"
+CVE_VERSION = "${@d.getVar('PV').split('stable')[1]}"
+
inherit deploy
PARALLEL_MAKE = ""