summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/musl
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-03-24 23:33:24 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-26 09:33:28 +0000
commit56c0629caebd7f22a09925333c2dc800901d7794 (patch)
treef1ef37dbcbbf2ac30976994237ee30873df88a95 /meta/recipes-core/musl
parentf7fd194feb4f7993518388160acd5199fcfc3b26 (diff)
downloadopenembedded-core-56c0629caebd7f22a09925333c2dc800901d7794.tar.gz
musl: Update to latest master
brings following fixes * 6d8a5157 fix invalid free of duplocale object when malloc has been replaced * 760f5d7e fix __WORDSIZE on x32 sys/user.h * bdb54540 sys/ptrace.h: add PTRACE_GET_RSEQ_CONFIGURATION from linux v5.13 * aa3bab6c sys/prctl.h: add PR_PAC_{SET,GET}_ENABLED_KEYS from linux v5.13 * a8300f5d elf.h: add NT_ARM_PAC_ENABLED_KEYS from linux v5.13 * dda21f10 netinet/in.h: add INADDR_DUMMY from linux v5.13 * ee05b11b bits/syscall.h: add landlock syscalls from linux v5.13 * 1ee8109e netinet/tcp.h: add tcp_zerocopy_receive fields from linux v5.12 * bc89c311 netinet/tcp.h: add TCP_NLA_* values up to linux v5.12 * 9ffd1454 s390x: add ptrace requests from linux v5.12 * f7d3db5b bits/syscall.h: add mount_setattr from linux v5.12 * e99c4258 signal.h: add new sa_flags from linux v5.11 * 993cccce signal.h: add SYS_USER_DISPATCH si_code value from linux v5.11 * 3dcbd896 signal.h: add si_code values for SIGSYS * 30c8a145 netinet/tcp.h: add tcp zerocopy related changes from linux v5.11 * b54f481f netinet/if_ether.h: add ETH_P_CFM from linux v5.11 * c5ecaca7 sys/socket.h: add new SO_ socket options from linux v5.11 * f35b99b3 sys/prctl.h: add PR_SET_SYSCALL_USER_DISPATCH from linux v5.11 * b21f3ded bits/syscall.h: add epoll_pwait2 from linux v5.11 * 3aba2150 nice: return EPERM instead of EACCES * 74a28a8a protect stack canary from leak via read-as-string by zeroing second byte * 7c0c7a75 math: avoid runtime conversions of floating-point constants Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Diffstat (limited to 'meta/recipes-core/musl')
-rw-r--r--meta/recipes-core/musl/musl_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-core/musl/musl_git.bb b/meta/recipes-core/musl/musl_git.bb
index 04752f40c4..d29097106f 100644
--- a/meta/recipes-core/musl/musl_git.bb
+++ b/meta/recipes-core/musl/musl_git.bb
@@ -4,7 +4,7 @@
require musl.inc
inherit linuxloader
-SRCREV = "f8bdc3048216f41eaaf655524fa286cfb1184a70"
+SRCREV = "6d8a515796270eb6cec8a278cb353a078a10f09a"
BASEVER = "1.2.2"