summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/kbd
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2019-12-24 09:54:49 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-12-30 08:45:03 +0000
commit2fb86f46baed43316086ce10de635c326e073c2d (patch)
tree971737f2a86df05bc6af67fd10c564780c71107b /meta/recipes-core/kbd
parent14f14eccf176539493fbfe710b66704feb7710da (diff)
downloadopenembedded-core-2fb86f46baed43316086ce10de635c326e073c2d.tar.gz
kbd: fix ptest can NOT run issue
After kbd updated to 2.2.0, it fails to run ptest: | make: *** No rule to make target 'libkbdfile-test01.c', needed by 'libkbdfile-test01'. Update sed expression to fix such kind of issues. And also make target dumpkeys-bkeymap and dumpkeys-bkeymap which are required by ptest. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/kbd')
-rw-r--r--meta/recipes-core/kbd/kbd_2.2.0.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-core/kbd/kbd_2.2.0.bb b/meta/recipes-core/kbd/kbd_2.2.0.bb
index f2521617e5..88041bc878 100644
--- a/meta/recipes-core/kbd/kbd_2.2.0.bb
+++ b/meta/recipes-core/kbd/kbd_2.2.0.bb
@@ -29,7 +29,7 @@ PACKAGECONFIG[pam] = "--enable-vlock, --disable-vlock, libpam,"
PACKAGECONFIG[tests] = "--enable-tests, --disable-tests, libcheck"
do_compile_ptest() {
- oe_runmake -C ${B}/tests dumpkeys-fulltable alt-is-meta
+ oe_runmake -C ${B}/tests alt-is-meta dumpkeys-bkeymap dumpkeys-fulltable dumpkeys-mktable
}
do_install_ptest() {
@@ -42,7 +42,7 @@ do_install_ptest() {
-e 's:${RECIPE_SYSROOT}::g' \
-e 's:${S}/config/missing::g' \
-e 's:${WORKDIR}::g' \
- -e '/libkeymap_.*_SOURCES =/d' -e '/$(EXEEXT):/,/^$/d' ${D}${PTEST_PATH}/tests/Makefile
+ -e '/^lib.*_SOURCES =/d' -e '/$(EXEEXT):/,/^$/d' ${D}${PTEST_PATH}/tests/Makefile
find ${B}/tests -executable -exec install {} ${D}${PTEST_PATH}/tests \;
find ${S}/tests \( -name \*.map -o -name \*.bin -o -name \*.output \) -exec install {} ${D}${PTEST_PATH}/tests \;