summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/initscripts/init-system-helpers_1.66.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-11-29 07:37:41 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-12-02 17:15:30 +0000
commit1d3af466f58dc1e5299c55f7ad6179128da3a553 (patch)
tree15a10c6473654b9e71aebd7c899bffced19560c1 /meta/recipes-core/initscripts/init-system-helpers_1.66.bb
parent63eaf528e78819d479a12a3d2c7cdad5c55fe0e1 (diff)
downloadopenembedded-core-1d3af466f58dc1e5299c55f7ad6179128da3a553.tar.gz
init-system-helpers: upgrade 1.65.2 -> 1.66
Changelog: ========== * d/init.lintian-overrides: Silence warning about "Important" field 'Important: yes' instructs APT to warn the user before removing this package. * script/update-rc.d: DPKG_ROOT support for sysvinit * Add "Protected: yes" to package "init" The "Protected" field does the same as "Important" already did in apt, but is also understood by dpkg (since dpkg 1.20.1). * Bump Standards-Version to 4.6.2, no changes * Override Lintian warning for Protected: yes * deb-systemd-invoke: support reload/reexec. This is useful for the --user case, to provide a shortcut that loops over all active user sessions over D-Bus. * deb-systemd-invoke: support --no-dbus for reload/reexec. Provide common implementation for SIGHUP/SIGRTMIN+25 to reload/reexec the system or user instances. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/initscripts/init-system-helpers_1.66.bb')
-rw-r--r--meta/recipes-core/initscripts/init-system-helpers_1.66.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-core/initscripts/init-system-helpers_1.66.bb b/meta/recipes-core/initscripts/init-system-helpers_1.66.bb
new file mode 100644
index 0000000000..64e08aae68
--- /dev/null
+++ b/meta/recipes-core/initscripts/init-system-helpers_1.66.bb
@@ -0,0 +1,42 @@
+SUMMARY = "helper tools for all init systems"
+DESCRIPTION = "This package contains helper tools that are necessary for switching between \
+the various init systems that Debian contains (e. g. sysvinit or \
+systemd). An example is deb-systemd-helper, a script that enables systemd unit \
+files without depending on a running systemd. \
+\
+It also includes the \"service\", \"invoke-rc.d\", and \"update-rc.d\" scripts which \
+provide an abstraction for enabling, disabling, starting, and stopping \
+services for all supported Debian init systems as specified by the policy. \
+\
+While this package is maintained by pkg-systemd-maintainers, it is NOT \
+specific to systemd at all. Maintainers of other init systems are welcome to \
+include their helpers in this package."
+HOMEPAGE = "https://salsa.debian.org/debian/init-system-helpers"
+SECTION = "base"
+LICENSE = "BSD-3-Clause & GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://debian/copyright;md5=c4ec20aa158fa9de26ee1accf78dcaae"
+
+SRCREV = "a5439f465dc1d1d4e12329208dc321fb806009f4"
+SRC_URI = "git://salsa.debian.org/debian/init-system-helpers.git;protocol=https;branch=master"
+UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))(?!_exp)"
+
+S = "${WORKDIR}/git"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+ install -d -m 0755 ${D}${sbindir}
+ install -m 0755 ${S}/script/invoke-rc.d ${D}${sbindir}
+ install -m 0755 ${S}/script/service ${D}${sbindir}
+}
+
+PACKAGES += "${PN}-invoke-rc.d ${PN}-service"
+
+FILES:${PN} = ""
+FILES:${PN}-invoke-rc.d = "${sbindir}/invoke-rc.d"
+FILES:${PN}-service = "${sbindir}/service"
+
+ALLOW_EMPTY:${PN} = "1"
+
+RRECOMMENDS:${PN} += "${PN}-invoke-rc.d ${PN}-service"