summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-02-13 09:00:52 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-02-14 13:52:20 +0000
commitc100c709e746e7b7301c5e01cbf43572a225f00e (patch)
tree4e12dbcefc8c75d0fe8534c2b9e5ffae1321968f /meta/recipes-core/glibc
parent74ccdbd29e967192d57e9eb05a0f5b4e1d78a50a (diff)
downloadopenembedded-core-c100c709e746e7b7301c5e01cbf43572a225f00e.tar.gz
glibc: Update to bring mips32/clone3 fix
This patch is the only change applied with this update * 312e159626 mips: FIx clone3 implementation (BZ 31325) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc')
-rw-r--r--meta/recipes-core/glibc/glibc-version.inc2
-rw-r--r--meta/recipes-core/glibc/glibc/0024-mips-FIx-clone3-implementation-BZ-31325.patch83
-rw-r--r--meta/recipes-core/glibc/glibc_2.39.bb1
3 files changed, 1 insertions, 85 deletions
diff --git a/meta/recipes-core/glibc/glibc-version.inc b/meta/recipes-core/glibc/glibc-version.inc
index 0d86917f45..5b0705f696 100644
--- a/meta/recipes-core/glibc/glibc-version.inc
+++ b/meta/recipes-core/glibc/glibc-version.inc
@@ -1,6 +1,6 @@
SRCBRANCH ?= "release/2.39/master"
PV = "2.39+git"
-SRCREV_glibc ?= "63295e4fda1f6dab4bf7442706fe303bf283036c"
+SRCREV_glibc ?= "312e159626b67fe11f39e83e222cf4348a3962f3"
SRCREV_localedef ?= "fab74f31b3811df543e24b6de47efdf45b538abc"
GLIBC_GIT_URI ?= "git://sourceware.org/git/glibc.git;protocol=https"
diff --git a/meta/recipes-core/glibc/glibc/0024-mips-FIx-clone3-implementation-BZ-31325.patch b/meta/recipes-core/glibc/glibc/0024-mips-FIx-clone3-implementation-BZ-31325.patch
deleted file mode 100644
index b391c60958..0000000000
--- a/meta/recipes-core/glibc/glibc/0024-mips-FIx-clone3-implementation-BZ-31325.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-From b471cadd57e3fc1fce74b33fcf75c6844cfd68b3 Mon Sep 17 00:00:00 2001
-From: Adhemerval Zanella <adhemerval.zanella@linaro.org>
-Date: Thu, 1 Feb 2024 14:41:03 -0300
-Subject: [PATCH] mips: FIx clone3 implementation (BZ 31325)
-
-For o32 we need to setup a minimal stack frame to allow cprestore
-on __thread_start_clone3 (which instruct the linker to save the
-gp for PIC). Also, there is no guarantee by kABI that $8 will be
-preserved after syscall execution, so we need to save it on the
-provided stack.
-
-Checked on mipsel-linux-gnu.
-
-Upstream-Status: Submitted [https://patchwork.sourceware.org/project/glibc/patch/20240201174103.798138-1-adhemerval.zanella@linaro.org/]
-Reported-by: Khem Raj <raj.khem@gmail.com>
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- sysdeps/unix/sysv/linux/mips/clone3.S | 32 ++++++++++++++++++++++-----
- 1 file changed, 27 insertions(+), 5 deletions(-)
-
-diff --git a/sysdeps/unix/sysv/linux/mips/clone3.S b/sysdeps/unix/sysv/linux/mips/clone3.S
-index e9fec2fa47..481b8ae963 100644
---- a/sysdeps/unix/sysv/linux/mips/clone3.S
-+++ b/sysdeps/unix/sysv/linux/mips/clone3.S
-@@ -37,11 +37,6 @@
-
- .text
- .set nomips16
--#if _MIPS_SIM == _ABIO32
--# define EXTRA_LOCALS 1
--#else
--# define EXTRA_LOCALS 0
--#endif
- #define FRAMESZ ((NARGSAVE*SZREG)+ALSZ)&ALMASK
- GPOFF= FRAMESZ-(1*SZREG)
- NESTED(__clone3, SZREG, sp)
-@@ -68,8 +63,31 @@ NESTED(__clone3, SZREG, sp)
- beqz a0, L(error) /* No NULL cl_args pointer. */
- beqz a2, L(error) /* No NULL function pointer. */
-
-+#if _MIPS_SIM == _ABIO32
-+ /* Both stack and stack_size on clone_args are defined as uint64_t, and
-+ there is no need to handle values larger than to 32 bits for o32. */
-+# if __BYTE_ORDER == __BIG_ENDIAN
-+# define CL_STACKPOINTER_OFFSET 44
-+# define CL_STACKSIZE_OFFSET 52
-+# else
-+# define CL_STACKPOINTER_OFFSET 40
-+# define CL_STACKSIZE_OFFSET 48
-+# endif
-+
-+ /* For o32 we need to setup a minimal stack frame to allow cprestore
-+ on __thread_start_clone3. Also there is no guarantee by kABI that
-+ $8 will be preserved after syscall execution (so we need to save it
-+ on the provided stack). */
-+ lw t0, CL_STACKPOINTER_OFFSET(a0) /* Load the stack pointer. */
-+ lw t1, CL_STACKSIZE_OFFSET(a0) /* Load the stack_size. */
-+ addiu t1, -32 /* Update the stack size. */
-+ addu t2, t1, t0 /* Calculate the thread stack. */
-+ sw a3, 0(t2) /* Save argument pointer. */
-+ sw t1, CL_STACKSIZE_OFFSET(a0) /* Save the new stack size. */
-+#else
- move $8, a3 /* a3 is set to 0/1 for syscall success/error
- while a4/$8 is returned unmodified. */
-+#endif
-
- /* Do the system call, the kernel expects:
- v0: system call number
-@@ -125,7 +143,11 @@ L(thread_start_clone3):
-
- /* Restore the arg for user's function. */
- move t9, a2 /* Function pointer. */
-+#if _MIPS_SIM == _ABIO32
-+ PTR_L a0, 0(sp)
-+#else
- move a0, $8 /* Argument pointer. */
-+#endif
-
- /* Call the user's function. */
- jal t9
---
-2.43.0
-
diff --git a/meta/recipes-core/glibc/glibc_2.39.bb b/meta/recipes-core/glibc/glibc_2.39.bb
index 577ff1ad2c..b203060064 100644
--- a/meta/recipes-core/glibc/glibc_2.39.bb
+++ b/meta/recipes-core/glibc/glibc_2.39.bb
@@ -49,7 +49,6 @@ SRC_URI = "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
file://0021-fix-create-thread-failed-in-unprivileged-process-BZ-.patch \
file://0022-Avoid-hardcoded-build-time-paths-in-the-output-binar.patch \
file://0023-aarch64-configure-Pass-mcpu-along-with-march-to-dete.patch \
- file://0024-mips-FIx-clone3-implementation-BZ-31325.patch \
"
S = "${WORKDIR}/git"
B = "${WORKDIR}/build-${TARGET_SYS}"