summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2023-03-11 20:51:21 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-03-12 23:36:44 +0000
commita1b5afac108d9c94e8fc2ad8cfebfee16f6f243b (patch)
treed382c1c8fa28ceeb43870942198633b8a7febf65 /meta/recipes-core/glibc
parentf63647f742488117c2ff7196479a6b0a2da61ddc (diff)
downloadopenembedded-core-a1b5afac108d9c94e8fc2ad8cfebfee16f6f243b.tar.gz
glibc-tests: Add missing bash ptest dependency
The script has a bashism and needs bash to execute correctly. Mark it as such and add the missing bash dependency so it executes in minimal images. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/glibc')
-rw-r--r--meta/recipes-core/glibc/glibc-tests_2.37.bb2
-rwxr-xr-xmeta/recipes-core/glibc/glibc/run-ptest2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-core/glibc/glibc-tests_2.37.bb b/meta/recipes-core/glibc/glibc-tests_2.37.bb
index bb6ef06162..9352a058fb 100644
--- a/meta/recipes-core/glibc/glibc-tests_2.37.bb
+++ b/meta/recipes-core/glibc/glibc-tests_2.37.bb
@@ -27,7 +27,7 @@ python __anonymous() {
# Remove any leftovers from original glibc recipe
RPROVIDES:${PN} = "${PN}"
RRECOMMENDS:${PN} = ""
-RDEPENDS:${PN} = " glibc sed"
+RDEPENDS:${PN} = " glibc sed bash"
RDEPENDS:${PN}-ptest = "${PN}"
DEPENDS += "sed"
diff --git a/meta/recipes-core/glibc/glibc/run-ptest b/meta/recipes-core/glibc/glibc/run-ptest
index f637986105..c394b49866 100755
--- a/meta/recipes-core/glibc/glibc/run-ptest
+++ b/meta/recipes-core/glibc/glibc/run-ptest
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
# ptest script for glibc - to run time related tests to
# facilitate Y2038 validation
# Run with 'ptest-runner glibc-tests'