summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-06-10 08:50:21 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-06-13 22:10:29 +0100
commit63248d2cbd7a15aec5b864d0058fe919eb17c46c (patch)
tree459a9f5a2a3e1191332dcfd6d3664283872c4ad6 /meta/recipes-core/glibc
parent46bc280f86f77eb10c810eef55111c0e8246d834 (diff)
downloadopenembedded-core-63248d2cbd7a15aec5b864d0058fe919eb17c46c.tar.gz
glibc: Pass linker choice via compiler flags
glibc configury tries to detect ld version and assumes BFD or gold linker but when system ld is pointing to lld or mold it might fail the linker check, therefore pass LD variable to explicitly point at ld.bfd we are using BFD linker only to link glibc after all. Second problem in such a case is that some partial objects are linked with CC -r which will fail if we do not inform the compiler to use BFD linker thusly pass it via appending to CC variable Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Diffstat (limited to 'meta/recipes-core/glibc')
-rw-r--r--meta/recipes-core/glibc/glibc_2.37.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.37.bb b/meta/recipes-core/glibc/glibc_2.37.bb
index b27f98fb19..3387441cad 100644
--- a/meta/recipes-core/glibc/glibc_2.37.bb
+++ b/meta/recipes-core/glibc/glibc_2.37.bb
@@ -103,10 +103,12 @@ do_configure () {
# version check and doesn't really help with anything
(cd ${S} && gnu-configize) || die "failure in running gnu-configize"
find ${S} -name "configure" | xargs touch
- CPPFLAGS="" oe_runconf
+ CPPFLAGS="" LD="${HOST_PREFIX}ld.bfd ${TOOLCHAIN_OPTIONS}" oe_runconf
}
LDFLAGS += "-fuse-ld=bfd"
+CC += "-fuse-ld=bfd"
+
do_compile () {
base_do_compile
echo "Adjust ldd script"