summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/coreutils
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-01-09 20:49:41 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-01-12 11:51:18 +0000
commitcd31bb507bfb794379950dd0aa38b810ba194d2f (patch)
tree4aa538c3a8c42140417a3e1e11d65581cacc923e /meta/recipes-core/coreutils
parent7bb45591f9caa7ff6b065220927a26e8261e2866 (diff)
downloadopenembedded-core-cd31bb507bfb794379950dd0aa38b810ba194d2f.tar.gz
coreutils: Ignore line-bytes.sh and no-allocate tests on musl
bash fails in xmalloc when running these tests. More thorough investigation may reveal real cause, however, it seems to fail on other musl distros as well. Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-core/coreutils')
-rw-r--r--meta/recipes-core/coreutils/coreutils_9.4.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta/recipes-core/coreutils/coreutils_9.4.bb b/meta/recipes-core/coreutils/coreutils_9.4.bb
index f210df2e69..367b011988 100644
--- a/meta/recipes-core/coreutils/coreutils_9.4.bb
+++ b/meta/recipes-core/coreutils/coreutils_9.4.bb
@@ -210,4 +210,10 @@ do_install_ptest () {
sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest
}
+do_install_ptest:append:libc-musl () {
+ # these tests fail due to bash on musl systems
+ # xmalloc: cannot allocate 16146 bytes
+ sed -i -e '/tests\/dd\/no-allocate.sh/d' ${D}${PTEST_PATH}/Makefile
+ sed -i -e '/tests\/split\/line-bytes.sh/d' ${D}${PTEST_PATH}/Makefile
+}
FILES:${PN}-ptest += "${bindir}/getlimits"