summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-12-24 17:59:42 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-12-26 18:40:36 +0000
commita4409583e0f8187b0c0cbf92fbddeffef12fd8f5 (patch)
tree10f364ad838c8eacc3b27d026d97e39df595d9ed /meta/recipes-connectivity
parentdf8303ab2f0ca4b694b845016c8d7e0279a48fe7 (diff)
downloadopenembedded-core-a4409583e0f8187b0c0cbf92fbddeffef12fd8f5.tar.gz
libslirp: add recipe to continue slirp support in qemu
qemu 7.2 no longer carries libslirp in-tree, and so it has to be provided externally. Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-connectivity')
-rw-r--r--meta/recipes-connectivity/slirp/libslirp_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/slirp/libslirp_git.bb b/meta/recipes-connectivity/slirp/libslirp_git.bb
new file mode 100644
index 0000000000..334b786b9b
--- /dev/null
+++ b/meta/recipes-connectivity/slirp/libslirp_git.bb
@@ -0,0 +1,18 @@
+SUMMARY = "A general purpose TCP-IP emulator"
+DESCRIPTION = "A general purpose TCP-IP emulator used by virtual machine hypervisors to provide virtual networking services."
+HOMEPAGE = "https://gitlab.freedesktop.org/slirp/libslirp"
+LICENSE = "BSD-3-Clause & MIT"
+LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=bca0186b14e6b05e338e729f106db727"
+
+SRC_URI = "git://gitlab.freedesktop.org/slirp/libslirp.git;protocol=https;branch=master"
+SRCREV = "3ad1710a96678fe79066b1469cead4058713a1d9"
+PV = "4.7.0"
+S = "${WORKDIR}/git"
+
+DEPENDS = " \
+ glib-2.0 \
+"
+
+inherit meson pkgconfig
+
+BBCLASSEXTEND = "native nativesdk"