summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/iproute2
diff options
context:
space:
mode:
authorTrevor Gamblin <tgamblin@baylibre.com>2023-07-21 08:48:09 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-07-25 15:27:30 +0100
commitae2a9b8d3a8b119cc021b9c99cac72d18d5954ba (patch)
tree7e12f2053de79386b1fcd480307ee508e2142259 /meta/recipes-connectivity/iproute2
parent0c13dac8fe3f432b7756c57a5892f8ab99d43166 (diff)
downloadopenembedded-core-ae2a9b8d3a8b119cc021b9c99cac72d18d5954ba.tar.gz
iproute2: upgrade 6.3.0 -> 6.4.0
Changelog: https://git.kernel.org/pub/scm/network/iproute2/iproute2.git/log/ Added a patch for including limits.h with musl builds, or else we get failures such as: | mdb.c: In function 'mdb_parse_vni': | mdb.c:666:47: error: 'ULONG_MAX' undeclared (first use in this function) | 666 | if ((endptr && *endptr) || vni_num == ULONG_MAX) | | ^~~~~~~~~ | mdb.c:666:47: note: 'ULONG_MAX' is defined in header '<limits.h>'; did you forget to '#include <limits.h>'? Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Diffstat (limited to 'meta/recipes-connectivity/iproute2')
-rw-r--r--meta/recipes-connectivity/iproute2/iproute2/0001-bridge-mdb.c-include-limits.h.patch41
-rw-r--r--meta/recipes-connectivity/iproute2/iproute2_6.4.0.bb (renamed from meta/recipes-connectivity/iproute2/iproute2_6.3.0.bb)3
2 files changed, 43 insertions, 1 deletions
diff --git a/meta/recipes-connectivity/iproute2/iproute2/0001-bridge-mdb.c-include-limits.h.patch b/meta/recipes-connectivity/iproute2/iproute2/0001-bridge-mdb.c-include-limits.h.patch
new file mode 100644
index 0000000000..f9a0e35d83
--- /dev/null
+++ b/meta/recipes-connectivity/iproute2/iproute2/0001-bridge-mdb.c-include-limits.h.patch
@@ -0,0 +1,41 @@
+From b13f04c0c685b6d2474aa7d97e191531f327bc45 Mon Sep 17 00:00:00 2001
+From: Trevor Gamblin <tgamblin@baylibre.com>
+Date: Thu, 20 Jul 2023 14:32:23 -0400
+Subject: [PATCH] bridge/mdb.c: include limits.h
+
+Upstream-Status: Submitted
+(https://lore.kernel.org/netdev/20230720203726.2316251-1-tgamblin@baylibre.com/)
+
+While building iproute2 6.4.0 with musl using Yocto Project, errors such
+as the following were encountered:
+
+| mdb.c: In function 'mdb_parse_vni':
+| mdb.c:666:47: error: 'ULONG_MAX' undeclared (first use in this function)
+| 666 | if ((endptr && *endptr) || vni_num == ULONG_MAX)
+| | ^~~~~~~~~
+| mdb.c:666:47: note: 'ULONG_MAX' is defined in header '<limits.h>'; did you forget to '#include <limits.h>'?
+
+Include limits.h in bridge/mdb.c to fix this issue. This change is based
+on one in Alpine Linux, but the author there had no plans to submit:
+https://git.alpinelinux.org/aports/commit/main/iproute2/include.patch?id=bd46efb8a8da54948639cebcfa5b37bd608f1069
+
+Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
+---
+ bridge/mdb.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/bridge/mdb.c b/bridge/mdb.c
+index fbb4f704..18793458 100644
+--- a/bridge/mdb.c
++++ b/bridge/mdb.c
+@@ -15,6 +15,7 @@
+ #include <string.h>
+ #include <arpa/inet.h>
+ #include <netdb.h>
++#include <limits.h>
+
+ #include "libnetlink.h"
+ #include "utils.h"
+--
+2.41.0
+
diff --git a/meta/recipes-connectivity/iproute2/iproute2_6.3.0.bb b/meta/recipes-connectivity/iproute2/iproute2_6.4.0.bb
index 892fa854da..32e2f8176b 100644
--- a/meta/recipes-connectivity/iproute2/iproute2_6.3.0.bb
+++ b/meta/recipes-connectivity/iproute2/iproute2_6.4.0.bb
@@ -13,9 +13,10 @@ DEPENDS = "flex-native bison-native iptables libcap"
SRC_URI = "${KERNELORG_MIRROR}/linux/utils/net/${BPN}/${BP}.tar.xz \
file://0001-libc-compat.h-add-musl-workaround.patch \
+ file://0001-bridge-mdb.c-include-limits.h.patch \
"
-SRC_URI[sha256sum] = "dfb2a98db96e7a653cffc6693335a1a466e29a34b6ac528be48f35e1d2766732"
+SRC_URI[sha256sum] = "4c51b8decbc7e4da159ffb066f590cfb93dbf9af7ff86b1647ce42b7c179a272"
inherit update-alternatives bash-completion pkgconfig