summaryrefslogtreecommitdiffstats
path: root/meta/packages/udev
diff options
context:
space:
mode:
authorRichard Purdie <richard@openedhand.com>2006-07-26 21:26:34 +0000
committerRichard Purdie <richard@openedhand.com>2006-07-26 21:26:34 +0000
commitd8201adda0f1cdab90dbf50c40abedb74d88a377 (patch)
treec25c68f2d0274ffb88524c3636b937565e085c02 /meta/packages/udev
parentfd6ac121ca8690e38f61190dd0f55429d9af6f4b (diff)
downloadopenembedded-core-d8201adda0f1cdab90dbf50c40abedb74d88a377.tar.gz
udev: Fix inotify ARM syscall issue, removing boot time warning
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@555 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta/packages/udev')
-rw-r--r--meta/packages/udev/udev-092/arm_inotify_fix.patch17
-rw-r--r--meta/packages/udev/udev_092.bb3
2 files changed, 19 insertions, 1 deletions
diff --git a/meta/packages/udev/udev-092/arm_inotify_fix.patch b/meta/packages/udev/udev-092/arm_inotify_fix.patch
new file mode 100644
index 0000000000..4bd0d4d9b9
--- /dev/null
+++ b/meta/packages/udev/udev-092/arm_inotify_fix.patch
@@ -0,0 +1,17 @@
+Index: udev-092/udev_libc_wrapper.h
+===================================================================
+--- udev-092.orig/udev_libc_wrapper.h 2006-07-26 21:55:06.000000000 +0100
++++ udev-092/udev_libc_wrapper.h 2006-07-26 21:55:37.000000000 +0100
+@@ -58,9 +58,9 @@
+ # define __NR_inotify_add_watch 152
+ # define __NR_inotify_rm_watch 156
+ #elif defined (__arm__)
+-# define __NR_inotify_init 316
+-# define __NR_inotify_add_watch 317
+-# define __NR_inotify_rm_watch 318
++# define __NR_inotify_init __NR_SYSCALL_BASE+316
++# define __NR_inotify_add_watch __NR_SYSCALL_BASE+317
++# define __NR_inotify_rm_watch __NR_SYSCALL_BASE+318
+ #elif defined (__sh__)
+ # define __NR_inotify_init 290
+ # define __NR_inotify_add_watch 291
diff --git a/meta/packages/udev/udev_092.bb b/meta/packages/udev/udev_092.bb
index f25eeb0946..4badbfc075 100644
--- a/meta/packages/udev/udev_092.bb
+++ b/meta/packages/udev/udev_092.bb
@@ -3,12 +3,13 @@ DESCRIPTION = "udev is a daemon which dynamically creates and removes device nod
the hotplug package and requires a kernel not older than 2.6.12."
RPROVIDES = "hotplug"
-PR = "r5"
+PR = "r6"
SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
file://noasmlinkage.patch;patch=1 \
file://flags.patch;patch=1 \
file://udevsynthesize.patch;patch=1 \
+ file://arm_inotify_fix.patch;patch=1 \
file://udevsynthesize.sh \
file://mount.blacklist"