summaryrefslogtreecommitdiffstats
path: root/meta/packages/apr
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2009-01-15 13:36:08 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2009-01-15 13:36:08 +0000
commit932fc6a37ddba80d6e52b55db4442df437d1cb61 (patch)
tree9ee2884c79676652070de04e392641ac1445e574 /meta/packages/apr
parent123b0991ee2f5a8ddb598b89271d6e27a29ea32b (diff)
downloadopenembedded-core-932fc6a37ddba80d6e52b55db4442df437d1cb61.tar.gz
apr: Disable checks for a system libtool, we don't need that
Diffstat (limited to 'meta/packages/apr')
-rw-r--r--meta/packages/apr/apr/cleanup.patch42
-rw-r--r--meta/packages/apr/apr_1.3.3.bb3
2 files changed, 44 insertions, 1 deletions
diff --git a/meta/packages/apr/apr/cleanup.patch b/meta/packages/apr/apr/cleanup.patch
new file mode 100644
index 0000000000..fd74826480
--- /dev/null
+++ b/meta/packages/apr/apr/cleanup.patch
@@ -0,0 +1,42 @@
+Index: apr-1.3.3/build/buildcheck.sh
+===================================================================
+--- apr-1.3.3.orig/build/buildcheck.sh 2009-01-15 13:32:33.000000000 +0000
++++ apr-1.3.3/build/buildcheck.sh 2009-01-15 13:33:06.000000000 +0000
+@@ -32,35 +32,4 @@
+ echo "buildconf: autoconf version $ac_version (ok)"
+ fi
+
+-# Sample libtool --version outputs:
+-# ltmain.sh (GNU libtool) 1.3.3 (1.385.2.181 1999/07/02 15:49:11)
+-# ltmain.sh (GNU libtool 1.1361 2004/01/02 23:10:52) 1.5a
+-# output is multiline from 1.5 onwards
+-
+-# Require libtool 1.4 or newer
+-libtool=`build/PrintPath glibtool libtool libtool15 libtool14`
+-lt_pversion=`$libtool --version 2>/dev/null|sed -e 's/([^)]*)//g;s/^[^0-9]*//;s/[- ].*//g;q'`
+-if test -z "$lt_pversion"; then
+-echo "buildconf: libtool not found."
+-echo " You need libtool version 1.4 or newer installed"
+-echo " to build APR from SVN."
+-exit 1
+-fi
+-lt_version=`echo $lt_pversion|sed -e 's/\([a-z]*\)$/.\1/'`
+-IFS=.; set $lt_version; IFS=' '
+-lt_status="good"
+-if test "$1" = "1"; then
+- if test "$2" -lt "4"; then
+- lt_status="bad"
+- fi
+-fi
+-if test $lt_status = "good"; then
+- echo "buildconf: libtool version $lt_pversion (ok)"
+- exit 0
+-fi
+-
+-echo "buildconf: libtool version $lt_pversion found."
+-echo " You need libtool version 1.4 or newer installed"
+-echo " to build APR from SVN."
+-
+-exit 1
++exit 0
+\ No newline at end of file
diff --git a/meta/packages/apr/apr_1.3.3.bb b/meta/packages/apr/apr_1.3.3.bb
index 4b4ce1118d..0d0fd667c0 100644
--- a/meta/packages/apr/apr_1.3.3.bb
+++ b/meta/packages/apr/apr_1.3.3.bb
@@ -2,10 +2,11 @@ DESCRIPTION = "Apache Portable Runtime (APR) library"
SECTION = "libs"
LICENSE = "Apache License, Version 2.0"
-PR = "r3"
+PR = "r4"
SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.bz2 \
file://configure_fixes.patch;patch=1 \
+ file://cleanup.patch;patch=1 \
file://configfix.patch;patch=1"
inherit autotools lib_package binconfig