summaryrefslogtreecommitdiffstats
path: root/meta-openmoko
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-11-05 15:48:38 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-11-05 15:48:38 +0000
commit139d1570605aeef3238a173ca90d81bb791d6b8a (patch)
tree0b41993a2a63e9e5eb1ebd8779837c37102aabb2 /meta-openmoko
parent5853cf2e14840e1ba15eeb78c474cc20813a8b4d (diff)
downloadopenembedded-core-139d1570605aeef3238a173ca90d81bb791d6b8a.tar.gz
dfu-util: added from OE
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3068 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-openmoko')
-rw-r--r--meta-openmoko/packages/dfu-util/dfu-util-native_svn.bb17
-rw-r--r--meta-openmoko/packages/dfu-util/dfu-util_svn.bb17
2 files changed, 34 insertions, 0 deletions
diff --git a/meta-openmoko/packages/dfu-util/dfu-util-native_svn.bb b/meta-openmoko/packages/dfu-util/dfu-util-native_svn.bb
new file mode 100644
index 0000000000..457094df9e
--- /dev/null
+++ b/meta-openmoko/packages/dfu-util/dfu-util-native_svn.bb
@@ -0,0 +1,17 @@
+require dfu-util_${PV}.bb
+
+inherit native
+
+DEPENDS = "libusb-native usbpath-native"
+
+do_stage() {
+ install -d ${STAGING_BINDIR_NATIVE}
+ install -m 0755 src/dfu-util ${STAGING_BINDIR_NATIVE}/
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0755 src/dfu-util_static ${DEPLOY_DIR_IMAGE}/dfu-util
+}
+
+addtask deploy before do_package after do_install
diff --git a/meta-openmoko/packages/dfu-util/dfu-util_svn.bb b/meta-openmoko/packages/dfu-util/dfu-util_svn.bb
new file mode 100644
index 0000000000..1f34a5bc24
--- /dev/null
+++ b/meta-openmoko/packages/dfu-util/dfu-util_svn.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "USB Device Firmware Upgrade utility"
+SECTION = "devel"
+AUTHOR = "Harald Welte"
+LICENSE = "GPL"
+PV = "0.1+svnr${SRCREV}"
+PR = "r0"
+
+DEPENDS = "libusb usbpath"
+
+SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=dfu-util;proto=http"
+S = "${WORKDIR}/dfu-util"
+
+inherit autotools
+
+do_stage() {
+ autotools_stage_all
+}