summaryrefslogtreecommitdiffstats
path: root/meta-extras/packages/python/python-2.5.1/fix-tkinter-detection.patch
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-11-15 13:55:06 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-11-15 13:55:06 +0000
commit3cfbc3b20b524748ec7253d6dfdc0c5eb17836cc (patch)
treed6731c1df8707972687bac18db0336599cfffe66 /meta-extras/packages/python/python-2.5.1/fix-tkinter-detection.patch
parenteaafa55d861b0a31e62895845730e778a0253ec9 (diff)
downloadopenembedded-core-3cfbc3b20b524748ec7253d6dfdc0c5eb17836cc.tar.gz
python: update to 2.5.1 from OE (without tcl/tk deps)
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3176 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta-extras/packages/python/python-2.5.1/fix-tkinter-detection.patch')
-rw-r--r--meta-extras/packages/python/python-2.5.1/fix-tkinter-detection.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-extras/packages/python/python-2.5.1/fix-tkinter-detection.patch b/meta-extras/packages/python/python-2.5.1/fix-tkinter-detection.patch
new file mode 100644
index 0000000000..93bd343381
--- /dev/null
+++ b/meta-extras/packages/python/python-2.5.1/fix-tkinter-detection.patch
@@ -0,0 +1,41 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+Index: Python-2.5.1/setup.py
+===================================================================
+--- Python-2.5.1.orig/setup.py
++++ Python-2.5.1/setup.py
+@@ -1227,7 +1227,7 @@ class PyBuildExt(build_ext):
+ dotversion = dotversion[:-1] + '.' + dotversion[-1]
+ tcl_include_sub = []
+ tk_include_sub = []
+- for dir in inc_dirs:
++ for dir in [os.getenv("STAGING_INCDIR")]:
+ tcl_include_sub += [dir + os.sep + "tcl" + dotversion]
+ tk_include_sub += [dir + os.sep + "tk" + dotversion]
+ tk_include_sub += tcl_include_sub
+@@ -1246,22 +1246,6 @@ class PyBuildExt(build_ext):
+ if dir not in include_dirs:
+ include_dirs.append(dir)
+
+- # Check for various platform-specific directories
+- if platform == 'sunos5':
+- include_dirs.append('/usr/openwin/include')
+- added_lib_dirs.append('/usr/openwin/lib')
+- elif os.path.exists('/usr/X11R6/include'):
+- include_dirs.append('/usr/X11R6/include')
+- added_lib_dirs.append('/usr/X11R6/lib64')
+- added_lib_dirs.append('/usr/X11R6/lib')
+- elif os.path.exists('/usr/X11R5/include'):
+- include_dirs.append('/usr/X11R5/include')
+- added_lib_dirs.append('/usr/X11R5/lib')
+- else:
+- # Assume default location for X11
+- include_dirs.append('/usr/X11/include')
+- added_lib_dirs.append('/usr/X11/lib')
+-
+ # If Cygwin, then verify that X is installed before proceeding
+ if platform == 'cygwin':
+ x11_inc = find_file('X11/Xlib.h', [], include_dirs)