summaryrefslogtreecommitdiffstats
path: root/meta-emenlow/packages/libva/libva-0.31.0/034_g45_fix_return_for_unimpl.patch
diff options
context:
space:
mode:
authorJeff Dike <jdike@x86_64.user-mode-linux.org>2010-07-21 17:31:45 -0400
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-21 22:39:43 +0100
commite8e3ac9b1e0e4342fc3a6d7b435ddaf93f274304 (patch)
treec8ed16e490e2e30de292c8a10eedb084d5abdea8 /meta-emenlow/packages/libva/libva-0.31.0/034_g45_fix_return_for_unimpl.patch
parent0c3b1aa0a5461c9b5f3833feb091f7c8a459ca9b (diff)
downloadopenembedded-core-e8e3ac9b1e0e4342fc3a6d7b435ddaf93f274304.tar.gz
meta-emenlow: Layer for eMenlow-based systems.
This layer provides a kernel suitable for booting on eMenlow-based systems, plus support for Poulsbo graphics. The Poulsbo support includes a kernel patch for the graphics driver, a couple of libraries, the 2D and 3D X drivers, and a properly configured X server. The closed portions of this support are in the 3D driver, xpsb-glx. This package contains the binaries for the libraries that communicate with the kernel driver and a mesa library which uses those libraries. There is a README in meta-emenlow/ describing how to enable this layer. Where possible, the recipes use bitbake's new .bbappend facility in order to avoid copying recipes from meta/. There are checksums and license information for all of the new packages. Signed-off-by: Jeff Dike <jdike@linux.intel.com>
Diffstat (limited to 'meta-emenlow/packages/libva/libva-0.31.0/034_g45_fix_return_for_unimpl.patch')
-rw-r--r--meta-emenlow/packages/libva/libva-0.31.0/034_g45_fix_return_for_unimpl.patch83
1 files changed, 83 insertions, 0 deletions
diff --git a/meta-emenlow/packages/libva/libva-0.31.0/034_g45_fix_return_for_unimpl.patch b/meta-emenlow/packages/libva/libva-0.31.0/034_g45_fix_return_for_unimpl.patch
new file mode 100644
index 0000000000..a4612133bb
--- /dev/null
+++ b/meta-emenlow/packages/libva/libva-0.31.0/034_g45_fix_return_for_unimpl.patch
@@ -0,0 +1,83 @@
+From 3935c6a836b8f90947f0af658a76b97a08a03c67 Mon Sep 17 00:00:00 2001
+From: Gwenole Beauchesne <gbeauchesne@splitted-desktop.com>
+Date: Wed, 4 Nov 2009 13:23:40 +0000
+Subject: [PATCH] [G45] Don't return VA_STATUS_SUCCESS for unimplemented functions.
+
+---
+ i965_drv_video/i965_drv_video.c | 18 +++++++++++-------
+ 1 files changed, 11 insertions(+), 7 deletions(-)
+
+diff --git a/i965_drv_video/i965_drv_video.c b/i965_drv_video/i965_drv_video.c
+index 10baffb..d8a7bd1 100644
+--- a/i965_drv_video/i965_drv_video.c
++++ b/i965_drv_video/i965_drv_video.c
+@@ -534,7 +534,8 @@ i965_SetSubpictureImage(VADriverContextP ctx,
+ VASubpictureID subpicture,
+ VAImageID image)
+ {
+- return VA_STATUS_SUCCESS;
++ /* TODO */
++ return VA_STATUS_ERROR_UNIMPLEMENTED;
+ }
+
+ VAStatus
+@@ -544,7 +545,8 @@ i965_SetSubpictureChromakey(VADriverContextP ctx,
+ unsigned int chromakey_max,
+ unsigned int chromakey_mask)
+ {
+- return VA_STATUS_SUCCESS;
++ /* TODO */
++ return VA_STATUS_ERROR_UNIMPLEMENTED;
+ }
+
+ VAStatus
+@@ -552,7 +554,8 @@ i965_SetSubpictureGlobalAlpha(VADriverContextP ctx,
+ VASubpictureID subpicture,
+ float global_alpha)
+ {
+- return VA_STATUS_SUCCESS;
++ /* TODO */
++ return VA_STATUS_ERROR_UNIMPLEMENTED;
+ }
+
+ VAStatus
+@@ -1141,7 +1144,7 @@ i965_GetDisplayAttributes(VADriverContextP ctx,
+ int num_attributes)
+ {
+ /* TODO */
+- return VA_STATUS_ERROR_UNKNOWN;
++ return VA_STATUS_ERROR_UNIMPLEMENTED;
+ }
+
+ /*
+@@ -1156,7 +1159,7 @@ i965_SetDisplayAttributes(VADriverContextP ctx,
+ int num_attributes)
+ {
+ /* TODO */
+- return VA_STATUS_ERROR_UNKNOWN;
++ return VA_STATUS_ERROR_UNIMPLEMENTED;
+ }
+
+ VAStatus
+@@ -1166,7 +1169,7 @@ i965_DbgCopySurfaceToBuffer(VADriverContextP ctx,
+ unsigned int *stride) /* out */
+ {
+ /* TODO */
+- return VA_STATUS_ERROR_UNKNOWN;
++ return VA_STATUS_ERROR_UNIMPLEMENTED;
+ }
+
+ static VAStatus
+@@ -1318,7 +1321,8 @@ VAStatus i965_DeriveImage(VADriverContextP ctx,
+ VASurfaceID surface,
+ VAImage *image) /* out */
+ {
+- return VA_STATUS_SUCCESS;
++ /* TODO */
++ return VA_STATUS_ERROR_OPERATION_FAILED;
+ }
+
+ static void
+--
+1.5.4.3
+