summaryrefslogtreecommitdiffstats
path: root/meta-emenlow/packages/libdrm-poulsbo
diff options
context:
space:
mode:
authorJeff Dike <jdike@x86_64.user-mode-linux.org>2010-07-22 17:30:49 -0400
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-22 23:18:26 +0100
commit833390e533ee997600f37ec87192f05e49e26db3 (patch)
tree670a6ff928f75bfc5e74a753e45acb64d97f72f7 /meta-emenlow/packages/libdrm-poulsbo
parentb18f1216b0d3654f7b6fb3752eda1dd82a294f3d (diff)
downloadopenembedded-core-833390e533ee997600f37ec87192f05e49e26db3.tar.gz
libdrm-poulsbo: Provide libdrm-poulsbo instead of libdrm
In order to allow this package to be build alongside the regular libdrm, it was made to export libdrm-poulsbo and its users make to use libdrm-poulsbo instead of libdrm. libva and xserver-psb were make to build against libdrm-poulsbo. While I was in there, I changed a couple of misspellings of COMPATIBLE and removed a bunch of ';patch=1'. Signed-off-by: Jeff Dike <jdike@linux.intel.com>
Diffstat (limited to 'meta-emenlow/packages/libdrm-poulsbo')
-rw-r--r--meta-emenlow/packages/libdrm-poulsbo/libdrm-poulsbo-2.3.0/libdrm-poulsbo.patch36
-rw-r--r--meta-emenlow/packages/libdrm-poulsbo/libdrm-poulsbo_2.3.0.bb12
2 files changed, 43 insertions, 5 deletions
diff --git a/meta-emenlow/packages/libdrm-poulsbo/libdrm-poulsbo-2.3.0/libdrm-poulsbo.patch b/meta-emenlow/packages/libdrm-poulsbo/libdrm-poulsbo-2.3.0/libdrm-poulsbo.patch
new file mode 100644
index 0000000000..e62188a7ac
--- /dev/null
+++ b/meta-emenlow/packages/libdrm-poulsbo/libdrm-poulsbo-2.3.0/libdrm-poulsbo.patch
@@ -0,0 +1,36 @@
+# Make this package produce libdrm-poulsbo instead of libdrm so that the
+# emenlow libdrm can coexist with the normal libdrm.
+# jdike@linux.intel.com
+
+Index: libdrm-poulsbo-2.3.0/configure.ac
+===================================================================
+--- libdrm-poulsbo-2.3.0.orig/configure.ac
++++ libdrm-poulsbo-2.3.0/configure.ac
+@@ -19,7 +19,7 @@
+ # CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+ AC_PREREQ(2.57)
+-AC_INIT([libdrm], 2.3.1, [dri-devel@lists.sourceforge.net], libdrm)
++AC_INIT([libdrm-poulsbo], 2.3.1, [dri-devel@lists.sourceforge.net], libdrm-poulsbo)
+ AC_CONFIG_SRCDIR([Makefile.am])
+ AM_INIT_AUTOMAKE([dist-bzip2])
+
+@@ -35,4 +35,4 @@ AC_SYS_LARGEFILE
+ pkgconfigdir=${libdir}/pkgconfig
+ AC_SUBST(pkgconfigdir)
+
+-AC_OUTPUT([Makefile libdrm/Makefile shared-core/Makefile libdrm.pc])
++AC_OUTPUT([Makefile libdrm/Makefile shared-core/Makefile libdrm-poulsbo.pc])
+Index: libdrm-poulsbo-2.3.0/Makefile.am
+===================================================================
+--- libdrm-poulsbo-2.3.0.orig/Makefile.am
++++ libdrm-poulsbo-2.3.0/Makefile.am
+@@ -25,6 +25,6 @@ AUTOMAKE_OPTIONS = foreign
+ SUBDIRS = libdrm shared-core
+
+ pkgconfigdir = @pkgconfigdir@
+-pkgconfig_DATA = libdrm.pc
++pkgconfig_DATA = libdrm-poulsbo.pc
+
+-EXTRA_DIST = libdrm.pc.in
++EXTRA_DIST = libdrm-poulsbo.pc.in
diff --git a/meta-emenlow/packages/libdrm-poulsbo/libdrm-poulsbo_2.3.0.bb b/meta-emenlow/packages/libdrm-poulsbo/libdrm-poulsbo_2.3.0.bb
index 8a06dce8cc..3541501e9c 100644
--- a/meta-emenlow/packages/libdrm-poulsbo/libdrm-poulsbo_2.3.0.bb
+++ b/meta-emenlow/packages/libdrm-poulsbo/libdrm-poulsbo_2.3.0.bb
@@ -1,14 +1,16 @@
DESCRIPTION = "Userspace interface to kernel DRM services"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://MIT_License.txt;md5=732825ecdcf420261531d935fcd914a7"
-PR="r1"
+PR="r2"
-PROVIDES = "libdrm-poulsbo libdrm drm"
+PROVIDES = "libdrm-poulsbo"
inherit autotools pkgconfig
-SRC_URI = "https://launchpad.net/~gma500/+archive/ppa/+files/libdrm-poulsbo_2.3.0-1ubuntu0sarvatt4~1004um1ubuntu1.tar.gz"
+SRC_URI = "https://launchpad.net/~gma500/+archive/ppa/+files/libdrm-poulsbo_2.3.0-1ubuntu0sarvatt4~1004um1ubuntu1.tar.gz \
+ file://libdrm-poulsbo.patch"
-do_install_append() {
- cp ${D}/${libdir}/pkgconfig/libdrm.pc ${D}/${libdir}/pkgconfig/libdrm-poulsbo.pc
+do_configure_prepend() {
+ sed -e 's/-ldrm/-ldrm-poulsbo/' -e 's/libdrm/libdrm-poulsbo/' \
+ < ${S}/libdrm.pc.in > ${S}/libdrm-poulsbo.pc.in
}