summaryrefslogtreecommitdiffstats
path: root/handbook/Makefile
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-09-29 15:26:29 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-29 15:27:04 +0100
commit2624b6181411fe722c73ec95aba9ea8c3d92bca5 (patch)
treebb3c5db53c6c5fbbdb086c90a644ece12cda8e21 /handbook/Makefile
parent1e0e6f11850c7014700604f7e24f9579d8d19102 (diff)
downloadopenembedded-core-2624b6181411fe722c73ec95aba9ea8c3d92bca5.tar.gz
poky-doc-tools: Remove unnecessary autotools usage and simplfy structure
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'handbook/Makefile')
-rw-r--r--handbook/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/handbook/Makefile b/handbook/Makefile
index 502c951a7a..ee549f1cbf 100644
--- a/handbook/Makefile
+++ b/handbook/Makefile
@@ -1,10 +1,8 @@
all: html pdf tarball
pdf:
- ./poky-doc-tools/poky-docbook-to-pdf poky-handbook.xml
- ./poky-doc-tools/poky-docbook-to-pdf bsp-guide.xml
-# -- old way --
-# dblatex poky-handbook.xml
+ ./tools/poky-docbook-to-pdf poky-handbook.xml ./template
+ ./tools/poky-docbook-to-pdf bsp-guide.xml ./template
XSLTOPTS = --stringparam html.stylesheet style.css \
--stringparam chapter.autolabel 1 \
@@ -22,8 +20,6 @@ html:
# See http://www.sagehill.net/docbookxsl/HtmlOutput.html
xsltproc $(XSLTOPTS) -o poky-handbook.html $(XSL_XHTML_URI) poky-handbook.xml
xsltproc $(XSLTOPTS) -o bsp-guide.html $(XSL_XHTML_URI) bsp-guide.xml
-# -- old way --
-# xmlto xhtml-nochunks poky-handbook.xml
tarball: html
tar -cvzf poky-handbook.tgz poky-handbook.html style.css screenshots/ss-sato.png poky-beaver.png poky-handbook.png
@@ -36,3 +32,6 @@ SOURCES = *.png *.xml *.css *.svg
publish:
scp -r $(OUTPUTS) $(SOURCES) o-hand.com:/srv/www/pokylinux.org/doc/
+
+clean:
+ rm $(OUTPUTS)