summaryrefslogtreecommitdiffstats
path: root/handbook/Makefile
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2010-06-04 14:48:34 +0100
committerJoshua Lock <josh@linux.intel.com>2010-06-04 20:02:06 +0100
commit1ccbc1549ec509d737dc39a9440aae1650bde1ad (patch)
treea8f16a01b1e3a52bac7f0991f806855291fe4b1d /handbook/Makefile
parentf5d0471541ddc29f11c2f17075fd8d46adea740d (diff)
downloadopenembedded-core-1ccbc1549ec509d737dc39a9440aae1650bde1ad.tar.gz
handbook: use XML catalogues to make building work on all(?) distros
Thanks to Damien's pointers we should now be able to generate the handbook regardless of host distro Signed-off-by: Joshua Lock <josh@linux.intel.com>
Diffstat (limited to 'handbook/Makefile')
-rw-r--r--handbook/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/handbook/Makefile b/handbook/Makefile
index 01353b11af..5dff1a8742 100644
--- a/handbook/Makefile
+++ b/handbook/Makefile
@@ -1,7 +1,6 @@
all: html pdf tarball
pdf:
-
./poky-doc-tools/poky-docbook-to-pdf poky-handbook.xml
./poky-doc-tools/poky-docbook-to-pdf bsp-guide.xml
# -- old way --
@@ -11,12 +10,17 @@ XSLTOPTS = --stringparam html.stylesheet style.css \
--stringparam chapter.autolabel 1 \
--stringparam appendix.autolabel 1 \
--stringparam section.autolabel 1
-XSLTOPTS2 = --xinclude /usr/share/xml/docbook/stylesheet/nwalsh/html/docbook.xsl
+
+##
+# These URI should be rewritten by your distribution's xml catalog to
+# match your localy installed XSL stylesheets.
+XSL_BASE_URI = http://docbook.sourceforge.net/release/xsl/current
+XSL_XHTML_URI = $(XSL_BASE_URI)/xhtml/docbook.xsl
html:
# See http://www.sagehill.net/docbookxsl/HtmlOutput.html
- xsltproc $(XSLTOPTS) -o poky-handbook.html $(XSLTOPTS2) poky-handbook.xml
- xsltproc $(XSLTOPTS) -o bsp-guide.html $(XSLTOPTS2) bsp-guide.xml
+ xsltproc $(XSLTOPTS) -o poky-handbook.html $(XSL_XHTML_URI) poky-handbook.xml
+ xsltproc $(XSLTOPTS) -o bsp-guide.html $(XSL_XHTML_URI) bsp-guide.xml
# -- old way --
# xmlto xhtml-nochunks poky-handbook.xml