summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-02-01 11:02:26 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-02-01 11:02:26 +0000
commitda21a63d48f9fabd97efb0095da2bb86639bcd7a (patch)
tree5b2673c50704195ce76523f6b2a7162cbe5a1826
parent116e25e86d185b4ee549e98baf09006d40ef055a (diff)
downloadopenembedded-core-da21a63d48f9fabd97efb0095da2bb86639bcd7a.tar.gz
gettext: Apply upstream fix to work with recent autoconf/automake
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
-rw-r--r--meta/packages/gettext/gettext-0.17/m4fix.patch50
-rw-r--r--meta/packages/gettext/gettext_0.17.bb3
2 files changed, 52 insertions, 1 deletions
diff --git a/meta/packages/gettext/gettext-0.17/m4fix.patch b/meta/packages/gettext/gettext-0.17/m4fix.patch
new file mode 100644
index 0000000000..a02457fab8
--- /dev/null
+++ b/meta/packages/gettext/gettext-0.17/m4fix.patch
@@ -0,0 +1,50 @@
+When I try to `./autogen.sh --quick' CVS gettext, using git Autoconf,
+things fall over like this (several instances):
+
+| gnulib-m4/openmp.m4:29: error: m4_copy: won't overwrite defined macro:
+_AC_LANG_OPENMP(C++)
+| gnulib-m4/openmp.m4:29: the top level
+| autom4te: /usr/bin/m4 failed with exit status: 1
+| aclocal: autom4te failed with exit status: 1
+
+I'm not quite sure whether an Autoconf bug/incompatibility is involved
+here (therefore the Cc: to bug-autoconf). m4_copy wasn't documented in
+earlier Autoconf releases, but there may still have been problematic
+semantic changes, I don't know.
+
+Anyway, the following patch seems to fix it. OK to apply?
+
+Cheers,
+Ralf
+
+2008-12-03 Ralf Wildenhues <[EMAIL PROTECTED]>
+
+ * m4/openmp.m4 (AC_OPENMP): Do not define with Autoconf 2.62 or
+ newer.
+
+Index: gettext-0.17/gettext-tools/gnulib-m4/openmp.m4
+===================================================================
+--- gettext-0.17.orig/gettext-tools/gnulib-m4/openmp.m4 2010-02-01 10:51:00.437788710 +0000
++++ gettext-0.17/gettext-tools/gnulib-m4/openmp.m4 2010-02-01 10:51:50.697789220 +0000
+@@ -1,11 +1,13 @@
+-# openmp.m4 serial 4
+-dnl Copyright (C) 2006-2007 Free Software Foundation, Inc.
++# openmp.m4 serial 5
++dnl Copyright (C) 2006-2008 Free Software Foundation, Inc.
+ dnl This file is free software; the Free Software Foundation
+ dnl gives unlimited permission to copy and/or distribute it,
+ dnl with or without modifications, as long as this notice is preserved.
+
+ dnl This file can be removed once we assume autoconf >= 2.62.
+
++m4_version_prereq([2.62],, [
++
+ # _AC_LANG_OPENMP
+ # ---------------
+ # Expands to some language dependent source code for testing the presence of
+@@ -90,3 +92,5 @@
+ fi
+ AC_SUBST([OPENMP_]_AC_LANG_PREFIX[FLAGS])
+ ])
++
++])
diff --git a/meta/packages/gettext/gettext_0.17.bb b/meta/packages/gettext/gettext_0.17.bb
index d4754c516a..fe4d167ad9 100644
--- a/meta/packages/gettext/gettext_0.17.bb
+++ b/meta/packages/gettext/gettext_0.17.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "The GNU internationalization library."
HOMEPAGE = "http://www.gnu.org/software/gettext/gettext.html"
SECTION = "libs"
LICENSE = "GPLv3"
-PR = "r4"
+PR = "r5"
DEPENDS = "gettext-native virtual/libiconv ncurses expat"
DEPENDS_virtclass-native = ""
PROVIDES = "virtual/libintl"
@@ -12,6 +12,7 @@ SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
file://autotools.patch;patch=1 \
file://wchar-uclibc.patch;patch=1 \
file://use_open_properly.patch;patch=1 \
+ file://m4fix.patch;patch=1 \
"
SRC_URI_append_linux-uclibc = " file://gettext-error_print_progname.patch;patch=1"