summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-11-02 16:17:51 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-11-05 11:21:02 +0000
commitbaff3647aea6b08eff7312eb45b60bc481830132 (patch)
tree340a4368652df879b107b142cb05aa5a0bdae99a
parentf318a13e8b6ce3ded313fa17ab80b35b936205fb (diff)
downloadopenembedded-core-baff3647aea6b08eff7312eb45b60bc481830132.tar.gz
createrepo-c: upgrade 1.0.1 -> 1.0.2
time64fix.patch removed since it's included in 1.0.2 Changelog: ========== Fix building on EL9 Don't allow building without zstd Adjust printf formats for 64bit time_t on 32bit systems Remove dependency on libmagic, hardcode magic number detection Add automation for uploading prebuilt binary wheels to PyPI Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
-rw-r--r--meta/recipes-devtools/createrepo-c/createrepo-c/time64fix.patch69
-rw-r--r--meta/recipes-devtools/createrepo-c/createrepo-c_1.0.2.bb (renamed from meta/recipes-devtools/createrepo-c/createrepo-c_1.0.1.bb)3
2 files changed, 1 insertions, 71 deletions
diff --git a/meta/recipes-devtools/createrepo-c/createrepo-c/time64fix.patch b/meta/recipes-devtools/createrepo-c/createrepo-c/time64fix.patch
deleted file mode 100644
index a63801ce26..0000000000
--- a/meta/recipes-devtools/createrepo-c/createrepo-c/time64fix.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-From 89e1c9415fb8438310036d5810cdb7da75ee3a7f Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Wed, 26 Jul 2023 12:27:14 -0700
-Subject: [PATCH] Adjust printf formats for 64bit time_t on 32bit systems
-
-Fixes format specifier mismatch warnings as well while here
-
-e.g.
-warning: format '%ld' expects argument of type 'long int', but argument 2 has type 'time_t'
-
-Upstream-Status: Submitted [https://github.com/rpm-software-management/createrepo_c/pull/376]
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- src/createrepo_c.c | 4 ++--
- src/misc.c | 4 ++--
- src/xml_dump_repomd.c | 2 +-
- 3 files changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/src/createrepo_c.c b/src/createrepo_c.c
-index 8681419..0f9048a 100644
---- a/src/createrepo_c.c
-+++ b/src/createrepo_c.c
-@@ -582,9 +582,9 @@ duplicates_warning(const char *nevra, GArray *locations, CmdDupNevra option)
- for (size_t i=0; i<locations->len; i++) {
- struct DuplicateLocation location = g_array_index(locations, struct
- DuplicateLocation, i);
-- g_warning(" Sourced from location: \'%s\', build timestamp: %ld%s",
-+ g_warning(" Sourced from location: \'%s\', build timestamp: %jd%s",
- location.location,
-- location.pkg->time_build,
-+ (intmax_t) location.pkg->time_build,
- location.pkg->skip_dump ? skip_reason : "");
-
- }
-diff --git a/src/misc.c b/src/misc.c
-index 8511ca2..7866c7b 100644
---- a/src/misc.c
-+++ b/src/misc.c
-@@ -1512,11 +1512,11 @@ cr_append_pid_and_datetime(const char *str, const char *suffix)
- gettimeofday(&tv, NULL);
- timeinfo = localtime (&(tv.tv_sec));
- strftime(datetime, 80, "%Y%m%d%H%M%S", timeinfo);
-- gchar *result = g_strdup_printf("%s%jd.%s.%ld%s",
-+ gchar *result = g_strdup_printf("%s%jd.%s.%jd%s",
- str ? str : "",
- (intmax_t) getpid(),
- datetime,
-- tv.tv_usec,
-+ (intmax_t) tv.tv_usec,
- suffix ? suffix : "");
- return result;
- }
-diff --git a/src/xml_dump_repomd.c b/src/xml_dump_repomd.c
-index 33b0e09..9d24249 100644
---- a/src/xml_dump_repomd.c
-+++ b/src/xml_dump_repomd.c
-@@ -143,7 +143,7 @@ cr_xml_dump_repomd_body(xmlNodePtr root, cr_Repomd *repomd)
- BAD_CAST repomd->revision);
- } else {
- // Use the current time if no revision was explicitly specified
-- gchar *rev = g_strdup_printf("%ld", time(NULL));
-+ gchar *rev = g_strdup_printf("%jd", (intmax_t) time(NULL));
- xmlNewChild(root, NULL, BAD_CAST "revision", BAD_CAST rev);
- g_free(rev);
- }
---
-2.41.0
-
diff --git a/meta/recipes-devtools/createrepo-c/createrepo-c_1.0.1.bb b/meta/recipes-devtools/createrepo-c/createrepo-c_1.0.2.bb
index 44d9213bd4..49d29bcfb4 100644
--- a/meta/recipes-devtools/createrepo-c/createrepo-c_1.0.1.bb
+++ b/meta/recipes-devtools/createrepo-c/createrepo-c_1.0.2.bb
@@ -7,10 +7,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
SRC_URI = "git://github.com/rpm-software-management/createrepo_c;branch=master;protocol=https \
file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
file://0001-include-rpm-rpmstring.h.patch \
- file://time64fix.patch \
"
-SRCREV = "e7af838e04009cd2f848a00e1ea31cc42c8f3ae7"
+SRCREV = "e87636334a3bc5d6ddfdb6c0b34042e96987efb1"
S = "${WORKDIR}/git"