summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-01-23 18:37:54 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-01-24 22:06:48 +0000
commitb49b9338667894ac3e45a3cd0c4db2d2db4d9053 (patch)
tree87aaf5142f5e0b28e5409f6963b10cb2658fba6e
parent5ac88d032968f4d005a61fc34f7e3e6e55426ccd (diff)
downloadopenembedded-core-b49b9338667894ac3e45a3cd0c4db2d2db4d9053.tar.gz
harfbuzz: Add missing <cstdio> and <cstdlib> includes
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/harfbuzz/harfbuzz/0001-test-threads-hb-subset-threads.cc-add-missing-cstdio.patch34
-rw-r--r--meta/recipes-graphics/harfbuzz/harfbuzz_6.0.0.bb3
2 files changed, 36 insertions, 1 deletions
diff --git a/meta/recipes-graphics/harfbuzz/harfbuzz/0001-test-threads-hb-subset-threads.cc-add-missing-cstdio.patch b/meta/recipes-graphics/harfbuzz/harfbuzz/0001-test-threads-hb-subset-threads.cc-add-missing-cstdio.patch
new file mode 100644
index 0000000000..13819f5cf8
--- /dev/null
+++ b/meta/recipes-graphics/harfbuzz/harfbuzz/0001-test-threads-hb-subset-threads.cc-add-missing-cstdio.patch
@@ -0,0 +1,34 @@
+From 7dfa672dac958bdbc7703ab0920e167eaa126754 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyich@gmail.com>
+Date: Mon, 16 Jan 2023 19:49:53 +0000
+Subject: [PATCH] test/threads/hb-subset-threads.cc: add missing <cstdio> include
+
+This week's `gcc-13` snapshot cleaned further up it's standard headers
+and exposed missing declaration as a build failure:
+
+ ../test/threads/hb-subset-threads.cc: In function 'void test_operation(operation_t, const char*, const test_input_t&)':
+ ../test/threads/hb-subset-threads.cc:127:3: error: 'printf' was not declared in this scope
+
+ ../test/threads/hb-subset-threads.cc: In function 'int main(int, char**)':
+ ../test/threads/hb-subset-threads.cc:157:19: error: 'atoi' was not declared in this scope
+
+Upstream-Status: Backport [https://github.com/harfbuzz/harfbuzz/commit/7dfa672dac958bdbc7703ab0920e167eaa126754]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ test/threads/hb-subset-threads.cc | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/test/threads/hb-subset-threads.cc b/test/threads/hb-subset-threads.cc
+index 9d86d8d51..f0e4b7e2a 100644
+--- a/test/threads/hb-subset-threads.cc
++++ b/test/threads/hb-subset-threads.cc
+@@ -1,4 +1,6 @@
+ #include <cassert>
++#include <cstdio>
++#include <cstdlib>
+ #include <cstring>
+ #include <thread>
+ #include <condition_variable>
+--
+2.39.1
+
diff --git a/meta/recipes-graphics/harfbuzz/harfbuzz_6.0.0.bb b/meta/recipes-graphics/harfbuzz/harfbuzz_6.0.0.bb
index ae54bad643..1fce127d07 100644
--- a/meta/recipes-graphics/harfbuzz/harfbuzz_6.0.0.bb
+++ b/meta/recipes-graphics/harfbuzz/harfbuzz_6.0.0.bb
@@ -8,7 +8,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6ee0f16281694fb6aa689cca1e0fb3da \
file://src/hb-ucd.cc;beginline=1;endline=15;md5=29d4dcb6410429195df67efe3382d8bc \
"
-SRC_URI = "${GITHUB_BASE_URI}/download/${PV}/${BPN}-${PV}.tar.xz"
+SRC_URI = "${GITHUB_BASE_URI}/download/${PV}/${BPN}-${PV}.tar.xz \
+ file://0001-test-threads-hb-subset-threads.cc-add-missing-cstdio.patch"
SRC_URI[sha256sum] = "1d1010a1751d076d5291e433c138502a794d679a7498d1268ee21e2d4a140eb4"
inherit meson pkgconfig lib_package gtk-doc gobject-introspection github-releases